2 thoughts on “webpack2: is not a loader (must have normal or pitch function)

  1. The reason is likely that you forgot to explicitly add the -loader extension to the configuration of your loader.
    See the migration guide.

    A more helpful error message would be welcome though.

  2. The reason is likely that you forgot to explicitly add the -loader extension to the configuration of your loader.

    Yes! That turned out to be the culprit indeed!

    Probably a change for the better.

    EDIT:
    oh and plus 1 for the message… Something like ‘could not resolve module ‘X’. Did you mean ‘X-loader’?’ would really have helped!

Comments are closed.