Update for Angular 7 support

  • update documentation extraction script to support TS 3.1.x
  • (warning) tslint version with CLI 7 marks keyEvent.which as deprecated
  • (warning) demo: tslint version with CLI 7 marks addListener as deprecated
  • update documentation with supported versions in README.md and getting-started.component.ts
  • required tsickle 0.33.0 gives a peer-depencency warning after installation with CLI 7.0.0 and TS 3.1.1

3 thoughts on “Update for Angular 7 support

  1. After update to Angular v7,

    npm WARN @ng-bootstrap/ng-bootstrap@3.3.0 requires a peer of @angular/common@^6.1.0 but none is installed. You must install peer dependencies yourself.
    npm WARN @ng-bootstrap/ng-bootstrap@3.3.0 requires a peer of @angular/core@^6.1.0 but none is installed. You must install peer dependencies yourself.
    npm WARN @ng-bootstrap/ng-bootstrap@3.3.0 requires a peer of @angular/forms@^6.1.0 but none is installed. You must install peer dependencies yourself.
    
  2. @changhuixu by saying that 3.x.x should work fine, I meant that there are no breaking changes / development required in the library to support Angular 7. Warnings is a different thing.

    We’ll release 4.0.0 shortly with official support for Angular 7.0.0, rxjs 6.3.0 and TS 3.1.1 that will remove all warnings in question.