Typescript 3.1.1 build error

Angular: 7.0.0-rc.0
Typescript: 3.1.1
ng-bootstrap: 3.2.2

New version of typescript causes prod build error:

ERROR in node_modules@ng-bootstrap\ng-bootstrap\ng-bootstrap.d.ts.ɵh.html(3,67): : An expression of type ‘void’ cannot be tested for truthiness
node_modules@ng-bootstrap\ng-bootstrap\ng-bootstrap.d.ts.ɵh.html(25,67): : An expression of type ‘void’ cannot be tested for truthiness

9 thoughts on “Typescript 3.1.1 build error

  1. Manually set “@ng-bootstrap/ng-bootstrap” to “^4.0.0”. Delete node_modules folder and reinstall with “npm i”. I solved right now. My package.json is like that:

    screen shot 2019-02-26 at 21 27 34