Tapable.plugin is deprecated. Use new API on `.hooks` instead

Do you want to request a feature or report a bug? Bug

What is the current behavior?

topic

https://travis-ci.org/julmot/form-components/builds/346048668#L4063-L4081

If the current behavior is a bug, please provide the steps to reproduce.

Run the build of this repository which uses these settings. PR: julmot/form-components#9

What is the expected behavior?

It shouldn’t fail or provide a meaningful message that helps resolving the issue. The current message looks like an internal error.

Please mention other relevant information such as the browser version, Node.js version, webpack version, and Operating System.

webpack v4
Win10
node v6.11.3

Author: Fantashit

22 thoughts on “Tapable.plugin is deprecated. Use new API on `.hooks` instead

  1. Just got the same issue directly after installing webpack

    webpack 4.0.0
    node 8.9.3
    text-webpack-plugin 3.0.2

  2. I think you have to install v4.0.0-alpha.0 of text-webpack-plugin.

    As you can see in the release notes under Code Refactoring: ExtractTextPlugin: update to new plugin system and API's.

  3. I’m no longer using extract-text-webpack-plugin anywhere, is there a way to find out which plugin is generating this warning?

  4. I’m sure using extract-text-webpack-plugin@next works if you’re getting the error from extract-text-webpack, but what if you’re not?

  5. I’m still getting:

    DeprecationWarning: Tapable.plugin is deprecated. Use new API on `.hooks` instead
    DeprecationWarning: Tapable.apply is deprecated. Call apply on the plugin directly instead
    

    with:

    "html-webpack-plugin": "^3.0.4"
    "extract-text-webpack-plugin": "^4.0.0-beta.0"
    

    same with or without "extract-text-webpack-plugin": "^4.0.0-beta.0"

  6. For everyone commenting here about using the latest version of X and still having the notices: Please run webpack using node --trace-deprecation ./node_modules/.bin/webpack. This is the only way to identify which package is using deprecated APIs.

    If you were doing this:

    webpack --bail --env dist -p
    

    Then please try this:

    node --trace-deprecation ./node_modules/.bin/webpack --bail --env dist -p
    

    If the stack trace shows that extract-text-webpack-plugin is responsible for the notice, please open an issue on its repository.

  7. I have tried all the solutions above and still get the same error. I even went as far as removing all plugins from my config file and got the same error.
    When I try to do a node trace to figure out the cause of the problem, I get the error;

    ERROR in Entry module not found: Error: Can't resolve './src' in '/home/jioke/lab/altalabs/ui'
    

    What could I possibly be doing wrong?

Comments are closed.