[Security] Change “Encode” to “Hash” to avoid any confusion

As mentioned:

@paragonie-scott you are right about this. Symfony should replace “encode” by “hash” everywhere. Sadly we cannot do this now because it will be a nightmare to do that change without breaking anything. I know it’s not the same, but the docs now explain this misnaming: http://symfony.com/doc/current/book/security.html#dynamically-encoding-a-password

Originally posted by @javiereguiluz in #17857 (comment)

Encode is an inaccurate term for what is actually done in the security component. Hash is the correct term.

I hope you agree that documenting the use of the term in the Symfony context was a temporary solution.

Symfony 5.4 would be a good time to rename all classes where encode is used and actually hash is done. The use of old names can be deprecated, and then removed in Symfony 6.0

4 thoughts on “[Security] Change “Encode” to “Hash” to avoid any confusion