RN@0.57.8 Red Screen with warning.length undefined

Description

I npm install’ed in my project and started getting red screen with message “warning.length undefined”. I even tried it on a fresh project, init –version@0.57.8, and its reproducible.

React Native version:

React Native Environment Info:
System:
OS: macOS 10.14.6
CPU: (4) x64 Intel(R) Core(TM) i5-5350U CPU @ 1.80GHz
Memory: 187.94 MB / 8.00 GB
Shell: 3.2.57 – /bin/bash
Binaries:
Node: 10.18.1 – /usr/local/bin/node
Yarn: 1.21.1 – /usr/local/bin/yarn
npm: 6.13.4 – /usr/local/bin/npm
Watchman: 4.9.0 – /usr/local/bin/watchman
SDKs:
iOS SDK:
Platforms: iOS 13.2, DriverKit 19.0, macOS 10.15, tvOS 13.2, watchOS 6.1
Android SDK:
API Levels: 23, 25, 26, 27, 28, 29
Build Tools: 27.0.3, 28.0.3, 29.0.2
System Images: android-28 | Google Play Intel x86 Atom, android-29 | Google APIs Intel x86 Atom
IDEs:
Android Studio: 3.5 AI-191.8026.42.35.6010548
Xcode: 11.3/11C29 – /usr/bin/xcodebuild
npmPackages:
react: 16.6.3 => 16.6.3
react-native: 0.57.8 => 0.57.8
npmGlobalPackages:
react-native-cli: 2.0.1

Steps To Reproduce

  1. react-native init NewProject –version react-native@0.57.8
  2. Run on Android, and you’ll see red screen as in screenshot.

Screenshot:

Screenshot_2020-03-24-23-40-50-301_com fareye

16 thoughts on “RN@0.57.8 Red Screen with warning.length undefined

  1. ⚠️ Using Old Version
    ℹ️ It looks like you are using an older version of React Native. Please upgrade to the latest version, and verify if the issue persists. If it does not, please let us know so we can close out this issue. This helps us ensure we are looking at issues that still exist in the current release.
  2. I can’t update RN version at this point of time it.
    Does anyone else facing this solution or have any work around ?

  3. Only happening with android for me. Is anyone else experiencing this with iOS as well?
    “react-native”: “0.58.6”,

  4. 0.57.8 (the version mentioned in the OP) was released on Dec 13, 2018. That was a very long time ago.

    All of you are stuck on 0.57.8 and reporting that you are having the same problem? That seems very surprising.

    We also aren’t going to be fixing anything a release from 15 months ago. I recommend seeing if this issue occurs on a recent release and opening a new issue with more recent information if it does.

  5. I had the same problem and found that the changes are related to @ babel / code-frame and some libraries that each new install adds changes in versions. I suggest you go back to a working commit and run a yarn again, so that you can proceed with the compilation.

  6. Try to add all required babel dependencies to your project directly. In my case added below @babel/* devDependencies and that worked for RN@0.57.8.

    “devDependencies”: {
    “@babel/core”: “7.8.3”
    }

  7. Pingback: 토토

Comments are closed.

RN@0.57.8 Red Screen with warning.length undefined

Description

I npm install’ed in my project and started getting red screen with message “warning.length undefined”. I even tried it on a fresh project, init –version@0.57.8, and its reproducible.

React Native version:

React Native Environment Info:
System:
OS: macOS 10.14.6
CPU: (4) x64 Intel(R) Core(TM) i5-5350U CPU @ 1.80GHz
Memory: 187.94 MB / 8.00 GB
Shell: 3.2.57 – /bin/bash
Binaries:
Node: 10.18.1 – /usr/local/bin/node
Yarn: 1.21.1 – /usr/local/bin/yarn
npm: 6.13.4 – /usr/local/bin/npm
Watchman: 4.9.0 – /usr/local/bin/watchman
SDKs:
iOS SDK:
Platforms: iOS 13.2, DriverKit 19.0, macOS 10.15, tvOS 13.2, watchOS 6.1
Android SDK:
API Levels: 23, 25, 26, 27, 28, 29
Build Tools: 27.0.3, 28.0.3, 29.0.2
System Images: android-28 | Google Play Intel x86 Atom, android-29 | Google APIs Intel x86 Atom
IDEs:
Android Studio: 3.5 AI-191.8026.42.35.6010548
Xcode: 11.3/11C29 – /usr/bin/xcodebuild
npmPackages:
react: 16.6.3 => 16.6.3
react-native: 0.57.8 => 0.57.8
npmGlobalPackages:
react-native-cli: 2.0.1

Steps To Reproduce

  1. react-native init NewProject –version react-native@0.57.8
  2. Run on Android, and you’ll see red screen as in screenshot.

Screenshot:

Screenshot_2020-03-24-23-40-50-301_com fareye

18 thoughts on “RN@0.57.8 Red Screen with warning.length undefined

  1. I can’t update RN version at this point of time it.
    Does anyone else facing this solution or have any work around ?

  2. Only happening with android for me. Is anyone else experiencing this with iOS as well?
    “react-native”: “0.58.6”,

  3. I had the same problem and found that the changes are related to @ babel / code-frame and some libraries that each new install adds changes in versions. I suggest you go back to a working commit and run a yarn again, so that you can proceed with the compilation.

  4. Try to add all required babel dependencies to your project directly. In my case added below @babel/* devDependencies and that worked for RN@0.57.8.

    “devDependencies”: {
    “@babel/core”: “7.8.3”
    }

Comments are closed.