requires ext-zip * -> the requested PHP extension zip is missing from your system.

MacOs

brew install php@7.3
brew link php@7.3 --force

Ubuntu

# For php v7.0
sudo apt-get install php7.0-zip

# For php v7.1
sudo apt-get install php7.1-zip

# For php v7.2
sudo apt-get install php7.2-zip

# For php v7.3
sudo apt-get install php7.3-zip

# For php v7.4
sudo apt-get install php7.4-zip

Centos

yum install php-pecl-zip