Proposal: Rename AxesHelper, GridHelper, PolarGridHelper

AxesHelper, GridHelper, and PolarGridHelper are not actually helpers, since they are not dependent on another object.

Is there support for renaming these objects to THREE.Axes, THREE.Grid, and THREE.PolarGrid?

Once concern is the axes helper is very limited, so removing the ‘helper’ nomenclature may be misleading to some users. (Users may expect more features, such as tick-marks and labels.)

ArrowHelper is also not dependent on another object. Maybe it could become THREE.Arrow.

Author: Fantashit

1 thought on “Proposal: Rename AxesHelper, GridHelper, PolarGridHelper

  1. Late feedback… 😅

    I see these as helpers really, as they’re helping to visualise the 3d world. I think the naming sets the right expectations compared to THREE.Water, THREE.Sky, etc

Comments are closed.