1 thought on “pandas.util.testing is deprecated. Use the functions in the public API at pandas.testing instead. from pandas.util.testing import assert_frame_equal

  1. I had the same issue. Resolved it.

    Just open in editor
    C:\Users\Amber\AppData\Local\Programs\Python\Python37\Lib\site-packages\pandas_datareader\compat_init_.py

    Replace:

    from pandas.util.testing import assert_frame_equal

    with

    from pandas.testing import assert_frame_equal

Comments are closed.