org-dartlang-debug:synthetic_debug_expression:1:1: Error

I got an error on my mac, what i did is just hot reload project after coding a sub widget, i tried to find out what is wrong, just like run AS instead of vc code, clean cache, and restart mac…please get my some idea, thank you~

dart : 2.2.0
flutter: 1.2.1

here is the log:

Launching lib/main.dart on iPhone XR in debug mode...

Compiler message:
org-dartlang-debug:synthetic_debug_expression:1:1: Error: Getter not found: '_debugCanPerformMutations'.
_debugCanPerformMutations
^^^^^^^^^^^^^^^^^^^^^^^^^
org-dartlang-debug:synthetic_debug_expression:1:1: Error: The getter '_debugCanPerformMutations' isn't defined for the class 'RenderViewport'.
 - 'RenderViewport' is from 'package:flutter/src/rendering/viewport.dart' ('file:///Users/makw/flutter/packages/flutter/lib/src/rendering/viewport.dart').
Try correcting the name to the name of an existing getter, or defining a getter or field named '_debugCanPerformMutations'.
_debugCanPerformMutations
^^^^^^^^^^^^^^^^^^^^^^^^^
org-dartlang-debug:synthetic_debug_expression:1:1: Error: Getter not found: '_semanticsConfiguration'.
_semanticsConfiguration
^^^^^^^^^^^^^^^^^^^^^^^
org-dartlang-debug:synthetic_debug_expression:1:1: Error: The getter '_semanticsConfiguration' isn't defined for the class 'RenderViewport'.
 - 'RenderViewport' is from 'package:flutter/src/rendering/viewport.dart' ('file:///Users/makw/flutter/packages/flutter/lib/src/rendering/viewport.dart').
Try correcting the name to the name of an existing getter, or defining a getter or field named '_semanticsConfiguration'.
_semanticsConfiguration
^^^^^^^^^^^^^^^^^^^^^^^

Author: Fantashit

3 thoughts on “org-dartlang-debug:synthetic_debug_expression:1:1: Error

  1. 16:18:08.544 1601 info flutter.tools [        ] org-dartlang-debug:synthetic_debug_expression:1:1: Error: The getter 'requestList' isn't defined for the class 'FirestoreProvider'.
    16:18:08.544 1602 info flutter.tools [        ]  - 'FirestoreProvider' is from 'package:elm_bluetooth_bloc/resources/firestore_provider.dart' ('elm_bluetooth_bloc/lib/resources/firestore_provider.dart').
    16:18:08.544 1603 info flutter.tools [        ] Try correcting the name to the name of an existing getter, or defining a getter or field named 'requestList'.
    16:18:08.546 1604 info flutter.tools [        ] requestList
    16:18:08.546 1605 info flutter.tools [        ] ^^^^^^^^^^^
    
    
    Doctor summary (to see all details, run flutter doctor -v):
    [√] Flutter (Channel master, v1.3.9-pre.29, on Microsoft Windows [Version 10.0.17134.590], locale en-US)
    [√] Android toolchain - develop for Android devices (Android SDK version 28.0.3)
    [√] Android Studio (version 3.3)
    [√] IntelliJ IDEA Community Edition (version 2017.3)
    [√] VS Code, 32-bit edition (version 1.30.1)
    [√] Connected device (1 available)
    
    

    I got the same problem. Deleting Breakpoints and variables and restart did not help
    After that a flutter clean worked. I get the problem quite often….

Comments are closed.