No published analyzer available for language version 2.10.0

Thank you for taking the time to file an issue!

This tracker is for issues related to:

  • Analyzer
  • Common Front End (CFE) and kernel
  • Dart core libraries (“dart:async”, “dart:io”, etc.)
  • Dart VM
  • dart2js
  • dartfix
  • dev_compiler

Some other pieces of the Dart ecosystem are maintained elsewhere. Please
file issues in their repository:

If you aren’t sure, file the issue here and we’ll find the right home for it.
In your issue, please include:

  • Dart SDK Version (dart --version)
  • Whether you are using Windows, MacOSX, or Linux (if applicable)
  • Whether you are using Chrome, Safari, Firefox, Edge (if applicable)

Missing some or all of the above might make the issue take longer or be
impossible to act on.

If you simply have a question, consider starting with Stack Overflow:

https://stackoverflow.com/questions/tagged/dart

For a real-time response, consider our Gitter channel:

https://gitter.im/dart-lang/sdk

5 thoughts on “No published analyzer available for language version 2.10.0

  1. How do we get this to work with Flutter?

    If I require the SDK version 2.10.0 (which is the dev channel of dart), I get the error:

    Running "flutter pub get" in my_app...                  
    The current Dart SDK version is 2.9.0-21.0.dev.flutter-20bf2fcf56.
    
    Because the app depends on build_runner >=1.10.2 which requires SDK version >=2.10.0-0.0 <3.0.0, version solving failed.
    pub get failed (1; Because the app depends on build_runner >=1.10.2 which requires SDK version >=2.10.0-0.0 <3.0.0, version solving failed.)
    

    This is on the dev branch of Flutter.

    The workaround seems to be switching to the flutter master branch: flutter channel master, but I’d prefer not to be there.

    Any help?

  2. @vaibhav135 This was the solution for us:

    dev_dependencies:
      build_runner: 1.10.1
    
    dependency_overrides:
      analyzer: 0.39.14
    

    Allows us to run the unstable versions of flutter, but the stable version of dart.