4 thoughts on “ng add with @ng-bootstrap/ng-bootstrap

  1. Tried ng add @ng-bootstrap/schematics but got this error.
    npm WARN bootstrap@4.1.1 requires a peer of jquery@1.9.1 - 3 but none is installed. You must install peer dependencies yourself.
    npm WARN bootstrap@4.1.1 requires a peer of popper.js@^1.14.3 but none is installed. You must install peer dependencies yourself.

    What is the point of using schematics if I still have to add other dependencies? I thought the ng add was suppose to do this.

  2. I have the same warning, using: ng add @ng-bootstrap/schematics.

    npm WARN bootstrap@4.1.1 requires a peer of jquery@1.9.1 - 3 but none is installed. You must install peer dependencies yourself.
    npm WARN bootstrap@4.1.1 requires a peer of popper.js@^1.14.3 but none is installed. You must install peer dependencies yourself.
    

    I can’t understanding the warning because the website say’s:

    Angular – specific widgets built from ground and using Bootstrap 4 CSS. APIs that makes sense in the Angular ecosystem. No dependencies on 3rd party JavaScript.

    So we need jquery and popper or not?

  3. I got the same error…
    no make sense.
    I prefer using this: npm install –save @ng-bootstrap/ng-bootstrap

    npm WARN bootstrap@4.1.1 requires a peer of jquery@1.9.1 – 3 but none is installed. You must install peer dependencies yourself.
    npm WARN bootstrap@4.1.1 requires a peer of popper.js@^1.14.3 but none is installed. You must install peer dependencies yourself.

  4. To anyone landing in this issue – missing peer dependencies on jQuery / popper is normal and intentional. The reason for this warning is that ng-bootstrap only needs Bootstrap CSS. It doesn’t require Bootstrap JS nor its dependencies.

    Unfortunately Bootstrap does not publish packages that would have CSS only (unless they are considering it).

    To cut the long story short: this warning is expected and there are technical limitations preventing us from getting rid of it. You do not need jQuery / popper to use ng-bootstrap and you should not install those manually.