‘NativeReanimated’ could not be found. Verify that a module by this name is registered in the native binary.

Current Behavior

  • Getting this error while configuring any kind of navigation

Your Environment

software version
iOS or Android 9
@react-navigation/native 5.9
react-native 0.63
expo
node 15.x
npm or yarn 7.4

1 possible answer(s) on “‘NativeReanimated’ could not be found. Verify that a module by this name is registered in the native binary.

  1. yes the support for reanimate 2 will be in react navigation v6, use reanimated v1 until it is supported in v5.