Many packages fail to install on windows build

Windows 8 build v0.96.0

Most packages fail to build through atom.
I’m kind of conflicted between posting here, or specific packages, but since almost every package fails, it might be an atom issue.

This is a typical log from anything that fails:

npm http GET https://registry.npmjs.org/emissary
npm http GET https://registry.npmjs.org/property-accessors
npm http GET https://registry.npmjs.org/underscore-plus
npm http GET https://registry.npmjs.org/mixto
npm http GET https://registry.npmjs.org/oniguruma
npm http GET https://registry.npmjs.org/pigments
npm http 304 https://registry.npmjs.org/underscore-plus
npm http 304 https://registry.npmjs.org/property-accessors
npm http 304 https://registry.npmjs.org/oniguruma
npm http 304 https://registry.npmjs.org/mixto
npm http 304 https://registry.npmjs.org/emissary
npm http 304 https://registry.npmjs.org/pigments
npm http GET https://registry.npmjs.org/underscore
npm http GET https://registry.npmjs.org/q
npm http 304 https://registry.npmjs.org/underscore
npm http 304 https://registry.npmjs.org/q
npm ERR! Error: ENOENT, lstat 'C:\Users\Josh\AppData\Local\Temp\apm-install-dir-114416-7352-z14m6b\node_modules\atom-color-highlight\node_modules\emissary\lib\subscriber.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "c:\\Program Files (x86)\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\bin\\node.exe" "c:\\Program Files (x86)\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\node_modules\\npm\\bin\\npm-cli.js" "--userconfig" "c:\\Program Files (x86)\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\.apmrc" "install" "C:\\Users\\Josh\\.atom\\.node-gyp\\.atom\\.apm\\atom-color-highlight\\0.13.2\\package.tgz" "--target=0.11.10" "--arch=ia32" "--msvs_version=2013"
npm ERR! cwd C:\Users\Josh\AppData\Local\Temp\apm-install-dir-114416-7352-z14m6b
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.4
npm ERR! path C:\Users\Josh\AppData\Local\Temp\apm-install-dir-114416-7352-z14m6b\node_modules\atom-color-highlight\node_modules\emissary\lib\subscriber.js
npm ERR! fstream_path C:\Users\Josh\AppData\Local\Temp\apm-install-dir-114416-7352-z14m6b\node_modules\atom-color-highlight\node_modules\emissary\lib\subscriber.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack c:\Program Files (x86)\Atom\resources\app\apm\node_modules\atom-package-manager\node_modules\npm\node_modules\fstream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, chmod 'C:\Users\Josh\AppData\Local\Temp\apm-install-dir-114416-7352-z14m6b\node_modules\atom-color-highlight\node_modules\oniguruma\deps'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "c:\\Program Files (x86)\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\bin\\node.exe" "c:\\Program Files (x86)\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\node_modules\\npm\\bin\\npm-cli.js" "--userconfig" "c:\\Program Files (x86)\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\.apmrc" "install" "C:\\Users\\Josh\\.atom\\.node-gyp\\.atom\\.apm\\atom-color-highlight\\0.13.2\\package.tgz" "--target=0.11.10" "--arch=ia32" "--msvs_version=2013"
npm ERR! cwd C:\Users\Josh\AppData\Local\Temp\apm-install-dir-114416-7352-z14m6b
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.4
npm ERR! path C:\Users\Josh\AppData\Local\Temp\apm-install-dir-114416-7352-z14m6b\node_modules\atom-color-highlight\node_modules\oniguruma\deps
npm ERR! fstream_path C:\Users\Josh\AppData\Local\Temp\apm-install-dir-114416-7352-z14m6b\node_modules\atom-color-highlight\node_modules\oniguruma\deps\onig\README
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! fstream_finish_call setupMadeDir
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack end (c:\Program Files (x86)\Atom\resources\app\apm\node_modules\atom-package-manager\node_modules\npm\node_modules\fstream\lib\writer.js:319:21)
npm ERR! fstream_stack c:\Program Files (x86)\Atom\resources\app\apm\node_modules\atom-package-manager\node_modules\npm\node_modules\fstream\lib\writer.js:336:20
npm ERR! fstream_stack next (c:\Program Files (x86)\Atom\resources\app\apm\node_modules\atom-package-manager\node_modules\npm\node_modules\fstream\lib\writer.js:366:20)
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! not found: git
npm ERR! 
npm ERR! Failed using git.
npm ERR! This is most likely not a problem with npm itself.
npm ERR! Please check if you have git installed and in your PATH.

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "c:\\Program Files (x86)\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\bin\\node.exe" "c:\\Program Files (x86)\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\node_modules\\npm\\bin\\npm-cli.js" "--userconfig" "c:\\Program Files (x86)\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\.apmrc" "install" "C:\\Users\\Josh\\.atom\\.node-gyp\\.atom\\.apm\\atom-color-highlight\\0.13.2\\package.tgz" "--target=0.11.10" "--arch=ia32" "--msvs_version=2013"
npm ERR! cwd C:\Users\Josh\AppData\Local\Temp\apm-install-dir-114416-7352-z14m6b
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.4
npm ERR! code ENOGIT
npm

Everything I’ve tried looks near identical to the above, with file name changes. Some longer than others due to dependencies also failing.

1 possible answer(s) on “Many packages fail to install on windows build