Flutter requires installation and setup of cocoapods in order to deploy apps on iOS devices

Flutter requires installation and setup of cocoapods in order to deploy apps on iOS devices.

The setup of cocoapods is crashing on the new macOS hardware, see https://feedbackassistant.apple.com/feedback/8612629

Would be nice if fluter switched to a different package management solution.

Comment blurb from @chinmaygarde

CocoaPods is used to manage native dependencies on the hosts. It seems like one of the dependencies of CocoaPods has a native dependency that is crashing on this host. We need to track a fix for this with CocoaPods or switch to a different package management solution.

1 possible answer(s) on “Flutter requires installation and setup of cocoapods in order to deploy apps on iOS devices

  1. FWIW, looks like upstream is tracking this in the following issues:

    Furthermore, in my situation I was able to (temporarily) work around the issue by running the sudo gem install cocoapods step under Rosetta. Not sure what downstream problems that might create, but it got me moving forward.