[error] package android.support.v4.util doesn’t exist

react-native-gesture-handler error

Hi,
I follow the instruction by the react-navigation website : https://reactnavigation.org/docs/en/getting-started.html to add react-navigation:

yarn add react-navigation

yarn add react-native-gesture-handler

react-native link react-native-gesture-handler

and successfully linked

info Linking "react-native-gesture-handler" iOS dependency info iOS module "react-native-gesture-handler" has been successfully linked info Linking "react-native-gesture-handler" Android dependency info Android module "react-native-gesture-handler" has been successfully linked

and then change the MainActivity.java like the docs it asks.

everything runs fine before adding navigation.

Then run react-native run-android emulator, and error pop up :

xxxx/node_modules/react-native-gesture-handler/android/src/main/java/com/swmansion/gesturehandler/react/RNGestureHandlerEvent.java:3: error: package android.support.v4.util doesn't exist import android.support.v4.util.Pools; ^ xxxx/android/src/main/java/com/swmansion/gesturehandler/react/RNGestureHandlerEvent.java:19: error: package Pools doesn't exist private static final Pools.SynchronizedPool<RNGestureHandlerEvent> EVENTS_POOL = ^

Your Environment

software version
react-navigation ^3.11.0
react-native 0.60.0
node v10.14.1
npm or yarn npm 6.4.1 yarn 1.16.0
react-native-gesture-handler ^1.3.0

I try to solve this by search in issues and stackoverflow, but non of them is working for me.
Any advice or help is needed . Thx.

Author: Fantashit

1 thought on “[error] package android.support.v4.util doesn’t exist

Comments are closed.