Default configuration file should be renamed

This one is for all code designers :).

The long webpack.config.js filename does not look right every time I look at my project’s directory structure. My proposal is to rename the default file to webpack.js or just add an additional default file name (like gulpfile.js, package.json).

It would also be helpful if we could add documentation on how to organize the code in case when projects get huge (it is kind of difficult to define everything inside a single file) – conventions, best practices. Well… I spend hours organizing the code because I like it clean and stylish.

What do you think?

Author: Fantashit

1 thought on “Default configuration file should be renamed

  1. @sirlancelot why put “file” in the name? That has always irritated me with gulpfile.js, it is redundant to name a file “file”. It would be similar to naming node_modules node_modules_folder. ESLint naming their config eslintConfig instead of just eslint in package.json also grinds my gears.

Comments are closed.