THREE.DEG = Math.PI / 180
geometry.rotateY( 90 * THREE.DEG );
looks better and shorter than:
geometry.rotateY( 90 * THREE.Math.DEG2RAD );
And looks semantically correct: “geometry rotate by Y to ninety degrees”
vs: “geometry rotate by Y to math ninety degrees to radians”
There is no any particular reason to pack this constant in Math module, If it is so often used.
And it will not cause confusion, but rather the opposite.
People will not ask the question “is the math, why is it not in THREE.Math ???” because we will not remove THREE.Math.DEG2RAD.