Could not resolve dependency: npm ERR! peer react@”^16.0″ from @react-native-community/masked-view@0.1.10

It can be a dumb issue, but I am creating an app with react-native first time. I need help as much as possible
Current Behavior
its a clean project and I am trying to install react-native stack-navigator using npm
However, I am getting an error that says
Found: react@17.0.1
npm ERR! node_modules/react
npm ERR! react@”17.0.1″ from the root project
npm ERR! peer react@”” from @react-navigation/stack@5.14.3
npm ERR! node_modules/@react-navigation/stack
npm ERR! @react-navigation/stack@”
” from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer react@”^16.0″ from @react-native-community/masked-view@0.1.10
npm ERR! node_modules/@react-native-community/masked-view
npm ERR! peer @react-native-community/masked-view@”>= 0.1.0″ from @react-navigation/stack@5.14.3
npm ERR! node_modules/@react-navigation/stack
npm ERR! @react-navigation/stack@”*” from the root project

when installing the environment, I also had a issue same as
react-native-masked-view/masked-view#111
According to this problem, I needed to install masked-view v0.2.3, not v0.1.0 to install in react-native 0.64.0, which is compatible with react version of 17.0.1.
How can I install stack navigator in react-native version 0.64.0? (Its same for the other navigators)
Expected Behavior
react-native drawer navigator installed and working

Your Environment

software Mac OS Catalina version 10.15.7
iOS and Android All
@react-navigation/native 5.9.3
@react-navigation/stack trying to install
react-native-gesture-handler 1.10.3
react-native-safe-area-context 3.2.0
react-native-screens 2.18.1
react-native 0.64.0
node 14.15.4
npm 7.6.0

1 possible answer(s) on “Could not resolve dependency: npm ERR! peer react@”^16.0″ from @react-native-community/masked-view@0.1.10