Consider renaming NoErrorsPlugin to something clearer like NoEmitOnErrorsPlugin

I’m submitting a feature request

The name of the NoErrorsPlugin is quite confusing. By name alone, I thought NoErrorsPlugin is a plugin which silences the display of any errors (no errors = don’t show errors), while in fact, it’s job is to skip the asset emit in case any errors are detected during the build stage.

I suggest NoEmitOnErrorsPlugin or SkipEmittingAssetsOnErrorsPlugin, but if you have better ideas, go for it.

Author: Fantashit

4 thoughts on “Consider renaming NoErrorsPlugin to something clearer like NoEmitOnErrorsPlugin

  1. I would accept a PR for this but it would need to be a graceful degradation:

    1. Add new Plugin with new name (identical functionality)
    2. When attempted use for old plugin need to provide deprecation warning explaining that the new named plugin should be used.
    3. Update tests to run against both plugins and then extra cases to verify deprecation warnings are emitted.
  2. NoEmitOnErrorsPlugin still sounds like something that should prevent it from emitting an error event when an error occurs… I personally think SkipEmittingAssetsOnErrorsPlugin would have been much less confusing.

Comments are closed.