Compilation error, Performing Test SUPPORT_GLIBCXX_USE_C99 Failed.

On a server with CentOS Linux release 7.2.1511
With the same environment (to ensure this, I just tried to compile pytorch1.1.0 and pytorch1.6.0 in the same terminal).
I tried to compile pytorch-1.1.0, pytorch-1.5.1 and pytorch-1.6.0 from source by python setup.py install.
Pytorch-1.1.0 can be compiled, but pytorch-1.5.1 and 1.6.0 failed, with Performing Test SUPPORT_GLIBCXX_USE_C99 Failed as shown below.
compiling pytorch1.1.0
b
compiling pytorch1.6.0
a
Issue #5229 can not solve this problem.

cc @malfet

1 possible answer(s) on “Compilation error, Performing Test SUPPORT_GLIBCXX_USE_C99 Failed.

  1. Pytorch-1.5 needs a C++14 compatible compiler. You are trying to compile PyTorch-1.6.0 with gcc-4.8.5, which is not fully C++14 compatible.
    Is there a reason why you can not try to compile it with at least gcc-5.4?