[!] CocoaPods did not set the base configuration of your project because your project already has a custom config set.

plugin

/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/universal-darwin19/rbconfig.rb:229: warning: Insecure world writable dir /usr/local/opt in PATH, mode 040777
Analyzing dependencies
Downloading dependencies
Installing Flutter (1.0.0)
Installing TZImagePickerController (3.4.2)
Installing panchao_image_picker (0.0.1)
Generating Pods project
Integrating client project
Pod installation complete! There are 3 dependencies from the Podfile and 3 total pods installed.

[!] CocoaPods did not set the base configuration of your project because your project already has a custom config set. In order for CocoaPods integration to work at all, please either set the base configurations of the target `Runner` to `Target Support Files/Pods-Runner/Pods-Runner.profile.xcconfig` or include the `Target Support Files/Pods-Runner/Pods-Runner.profile.xcconfig` in your build configuration (`Flutter/Release.xcconfig`).

1 possible answer(s) on “[!] CocoaPods did not set the base configuration of your project because your project already has a custom config set.

  1. Hi @pc1995

    Open the iOS project with xcode (ios folder)
    Select Runner From left menu
    Select Runner in PROJECT
    Select Info
    In Profile select the profile configuration
    In Debug select the debug configuration
    In Release select the release configuration

    IMG_20200920_165422

    @hamdikahloun
    Thank you so much ,thank you, thank you!