Cannot build App on Android

Hello, i’m working on an app that uses react native CLI for its android app.

I can successfully run :

npm start (launch development server)
react-native run-android

And i can work on the app with Developer Menu ect without any issue.

However, when i try to follow the guideline to build my app, it fails with :

> Task :app:bundleReleaseJsAndAssets
warning: the transform cache was reset.
error `fsevents` unavailable (this watcher can only be used on Darwin)

> Task :app:bundleReleaseJsAndAssets FAILED

> Task :app:bundleReleaseJsAndAssets_SentryUpload FAILED
Processing react-native sourcemaps for Sentry upload.
> Analyzing 2 sources
error: No such file or directory (os error 2)

Add --log-level=[info|debug] or export SENTRY_LOG_LEVEL=[info|debug] to see more output.
Please attach the full debug log to all bug reports.

FAILURE: Build completed with 2 failures.

1: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':app:bundleReleaseJsAndAssets'.
> Process 'command 'node'' finished with non-zero exit value 1

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to     get more log output. Run with --scan to get full insights.
==============================================================================

2: Task failed with an exception.
-----------
* What went wrong:
Execution failed for task ':app:bundleReleaseJsAndAssets_SentryUpload'.
> Process 'command 'node_modules/@sentry/cli/bin/sentry-cli'' finished with non-zero exit value 1

My react-native info is such as

  React Native Environment Info:
System:
  OS: macOS High Sierra 10.13.6
  CPU: x64 Intel(R) Core(TM) i7-4770HQ CPU @ 2.20GHz
  Memory: 4.85 GB / 16.00 GB
  Shell: 5.3 - /bin/zsh
Binaries:
  Node: 10.19.0 - ~/.nvm/versions/node/v10.19.0/bin/node
  Yarn: 1.22.0 - /usr/local/bin/yarn
  npm: 6.13.4 - ~/.nvm/versions/node/v10.19.0/bin/npm
SDKs:
  iOS SDK:
    Platforms: iOS 12.0, macOS 10.14, tvOS 12.0, watchOS 5.0
  Android SDK:
    Build Tools: 28.0.3, 29.0.3
    API Levels: 28, 29
IDEs:
  Android Studio: 3.5 AI-191.8026.42.35.6010548
  Xcode: 10.0/10A255 - /usr/bin/xcodebuild
npmPackages:
  react: 16.8.1 => 16.8.1 
  react-native: 0.59.5 => 0.59.5 
npmGlobalPackages:
  react-native-cli: 2.0.1

I have no idea what to test next, so any hint is welcome
Thanks

1 possible answer(s) on “Cannot build App on Android

  1. I think i had a conflict between some watchman servers while developing.
    So i’ve just rebooted my computer.

    And for Sentry, an old auth token was remaining in the configuration.