@angular-devkit/architect@0.1000.5′ is not in the npm registry

🐞 Bug report

Command (mark with an x)

  • npm install @angular/cli
  • new
  • build
  • serve
  • test
  • e2e
  • generate
  • add
  • update
  • lint
  • xi18n
  • run
  • config
  • help
  • version
  • doc

Is this a regression?

No

Description

Every time I try to run ng new app or npm install @angular/cli I got the same error from NPM:

npm ERR! 404 Not Found - GET https://registry.npmjs.org/@angular-devkit%%2farchitect - Not found

🔬 Minimal Reproduction

Just run ng new app or npm install @angular/cli

🔥 Exception or Error


$ sudo npm i @angular/cli -g
npm ERR! code E404
npm ERR! 404 Not Found - GET https://registry.npmjs.org/@angular-devkit%%2farchitect - Not found
npm ERR! 404
npm ERR! 404  '@angular-devkit/architect@0.1000.5' is not in the npm registry.
npm ERR! 404 You should bug the author to publish it (or use the name yourself!)
npm ERR! 404 It was specified as a dependency of '@angular/cli'
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.

🌍 Your Environment


Angular CLI: 9.1.12
Node: 13.7.0
OS: darwin x64

Angular:
...
Ivy Workspace:

Package                      Version
------------------------------------------------------
@angular-devkit/architect    0.901.12
@angular-devkit/core         9.1.12
@angular-devkit/schematics   9.1.12
@schematics/angular          9.1.12
@schematics/update           0.901.12
rxjs                         6.5.4

Tried also in dedicated server, located in different country, with the same result.

4 thoughts on “@angular-devkit/architect@0.1000.5′ is not in the npm registry