Android build failure on master channel

Steps to Reproduce

  1. flutter channel master
  2. flutter upgrade
  3. flutter run –flavor dev, or flutter build apk –flavor dev

Steps to try resolve

  1. flutter clean
  2. Delete gradle cache folders

Logs

Logs
flutter run --release --flavor dev -v  
[  +61 ms] executing: [C:\Work\flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%%H
[  +45 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%%H
[        ] 354bd53f62ed6dd31c9addc4cce521f412c6b1aa
[        ] executing: [C:\Work\flutter/] git tag --points-at 354bd53f62ed6dd31c9addc4cce521f412c6b1aa
[  +31 ms] Exit code 0 from: git tag --points-at 354bd53f62ed6dd31c9addc4cce521f412c6b1aa
[   +1 ms] executing: [C:\Work\flutter/] git describe --match *.*.* --long --tags 354bd53f62ed6dd31c9addc4cce521f412c6b1aa
[  +46 ms] Exit code 0 from: git describe --match *.*.* --long --tags 354bd53f62ed6dd31c9addc4cce521f412c6b1aa
[        ] 1.27.0-4.0.pre-134-g354bd53f62
[  +32 ms] executing: [C:\Work\flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[  +24 ms] Exit code 0 from: git rev-parse --abbrev-ref --symbolic @{u}
[        ] origin/master
[        ] executing: [C:\Work\flutter/] git ls-remote --get-url origin
[  +22 ms] Exit code 0 from: git ls-remote --get-url origin
[        ] https://github.com/flutter/flutter.git
[  +45 ms] executing: [C:\Work\flutter/] git rev-parse --abbrev-ref HEAD
[  +22 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] master
[  +43 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[   +2 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[   +5 ms] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[  +42 ms] executing: C:\Users\Sean\AppData\Local\Android\Sdk\platform-tools\adb.exe devices -l
[  +30 ms] List of devices attached
           39b812c                device product:whyred model:Redmi_Note_5 device:whyred transport_id:2
[   +4 ms] C:\Users\Sean\AppData\Local\Android\Sdk\platform-tools\adb.exe -s 39b812c shell getprop
[ +219 ms] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[   +5 ms] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[   +5 ms] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[  +72 ms] Skipping pub get: version match.
[  +14 ms] Found plugin keychain at C:\Work\flutter\.pub-cache\git\flutter-plugins-9c77e6954c5c4eb6d5ab2ca7825b319f96437098\keychain\keychain\
[   +3 ms] Found plugin keychain_linux at C:\Work\flutter\.pub-cache\git\flutter-plugins-9c77e6954c5c4eb6d5ab2ca7825b319f96437098\keychain\keychain_linux\
[   +1 ms] Found plugin keychain_macos at C:\Work\flutter\.pub-cache\git\flutter-plugins-9c77e6954c5c4eb6d5ab2ca7825b319f96437098\keychain\keychain_macos\
[   +1 ms] Found plugin keychain_windows at C:\Work\flutter\.pub-cache\git\flutter-plugins-9c77e6954c5c4eb6d5ab2ca7825b319f96437098\keychain\keychain_windows\
[   +9 ms] Found plugin sqflite at C:\Work\flutter\.pub-cache\git\sqflite_sqlcipher-bb2b0a7c95e3679e323c32d54722ad3f639147d8\sqflite\
[  +20 ms] Found plugin device_info at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\device_info-0.4.2+7\
[   +5 ms] Found plugin file_picker at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\file_picker-2.1.5\
[   +5 ms] Found plugin firebase_core at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_core-0.5.3\
[   +4 ms] Found plugin firebase_core_web at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_core_web-0.2.1+1\
[   +1 ms] Found plugin firebase_crashlytics at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_crashlytics-0.2.1+1\
[   +1 ms] Found plugin firebase_messaging at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_messaging-7.0.3\
[   +9 ms] Found plugin flutter_file_dialog at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_file_dialog-1.0.0\
[   +7 ms] Found plugin flutter_plugin_android_lifecycle at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_plugin_android_lifecycle-1.0.11\
[   +2 ms] Found plugin flutter_secure_storage at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_secure_storage-3.3.3\
[   +5 ms] Found plugin image_picker at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\image_picker-0.6.7+21\
[  +20 ms] Found plugin open_file at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\open_file-3.0.1\
[   +3 ms] Found plugin package_info at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\package_info-0.4.3\
[   +9 ms] Found plugin path_provider at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider-1.6.24\
[   +1 ms] Found plugin path_provider_linux at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_linux-0.0.1+2\
[        ] Found plugin path_provider_macos at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_macos-0.0.4+8\
[   +1 ms] Found plugin path_provider_windows at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_windows-0.0.4+3\
[  +16 ms] Found plugin sensors at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\sensors-0.4.2+6\
[  +17 ms] Found plugin sqflite_sqlcipher at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\sqflite_sqlcipher-1.1.4\
[  +10 ms] Found plugin url_launcher at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\url_launcher-5.4.10\
[   +9 ms] Found plugin url_launcher_macos at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\url_launcher_macos-0.0.1+9\
[   +1 ms] Found plugin url_launcher_web at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\url_launcher_web-0.1.5+3\
[  +10 ms] Found plugin video_player at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\video_player-0.10.11+1\
[   +1 ms] Found plugin video_player_web at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\video_player_web-0.1.4+1\
[  +65 ms] Found plugin keychain at C:\Work\flutter\.pub-cache\git\flutter-plugins-9c77e6954c5c4eb6d5ab2ca7825b319f96437098\keychain\keychain\
[        ] Found plugin keychain_linux at C:\Work\flutter\.pub-cache\git\flutter-plugins-9c77e6954c5c4eb6d5ab2ca7825b319f96437098\keychain\keychain_linux\
[        ] Found plugin keychain_macos at C:\Work\flutter\.pub-cache\git\flutter-plugins-9c77e6954c5c4eb6d5ab2ca7825b319f96437098\keychain\keychain_macos\
[   +2 ms] Found plugin keychain_windows at C:\Work\flutter\.pub-cache\git\flutter-plugins-9c77e6954c5c4eb6d5ab2ca7825b319f96437098\keychain\keychain_windows\
[   +9 ms] Found plugin sqflite at C:\Work\flutter\.pub-cache\git\sqflite_sqlcipher-bb2b0a7c95e3679e323c32d54722ad3f639147d8\sqflite\
[  +25 ms] Found plugin device_info at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\device_info-0.4.2+7\
[  +10 ms] Found plugin file_picker at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\file_picker-2.1.5\
[   +1 ms] Found plugin firebase_core at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_core-0.5.3\
[   +1 ms] Found plugin firebase_core_web at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_core_web-0.2.1+1\
[        ] Found plugin firebase_crashlytics at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_crashlytics-0.2.1+1\
[        ] Found plugin firebase_messaging at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_messaging-7.0.3\
[   +2 ms] Found plugin flutter_file_dialog at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_file_dialog-1.0.0\
[   +7 ms] Found plugin flutter_plugin_android_lifecycle at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_plugin_android_lifecycle-1.0.11\
[  +17 ms] Found plugin flutter_secure_storage at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_secure_storage-3.3.3\
[   +2 ms] Found plugin image_picker at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\image_picker-0.6.7+21\
[  +13 ms] Found plugin open_file at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\open_file-3.0.1\
[   +9 ms] Found plugin package_info at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\package_info-0.4.3\
[   +3 ms] Found plugin path_provider at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider-1.6.24\
[  +10 ms] Found plugin path_provider_linux at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_linux-0.0.1+2\
[        ] Found plugin path_provider_macos at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_macos-0.0.4+8\
[   +1 ms] Found plugin path_provider_windows at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_windows-0.0.4+3\
[   +4 ms] Found plugin sensors at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\sensors-0.4.2+6\
[   +9 ms] Found plugin sqflite_sqlcipher at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\sqflite_sqlcipher-1.1.4\
[   +4 ms] Found plugin url_launcher at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\url_launcher-5.4.10\
[   +8 ms] Found plugin url_launcher_macos at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\url_launcher_macos-0.0.1+9\
[   +1 ms] Found plugin url_launcher_web at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\url_launcher_web-0.1.5+3\
[   +1 ms] Found plugin video_player at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\video_player-0.10.11+1\
[   +8 ms] Found plugin video_player_web at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\video_player_web-0.1.4+1\
[  +15 ms] Generating C:\Work\...\android\app\src\main\java\io\flutter\plugins\GeneratedPluginRegistrant.java
[  +43 ms] ro.hardware = qcom
[  +43 ms] Launching lib\main.dart on Redmi Note 5 in release mode...
[   +2 ms] executing: C:\Users\Sean\AppData\Local\Android\Sdk\platform-tools\adb.exe -s 39b812c shell -x logcat -v time -t 1
[ +168 ms] --------- beginning of crash
                    02-24 14:56:28.857 F/linker  (11177): CANNOT LINK EXECUTABLE "/system/bin/dpmd": "/system/lib64/libdpmframework.so" is 32-bit instead of 64-bit
[   +8 ms] executing: C:\Users\Sean\AppData\Local\Android\Sdk\platform-tools\adb.exe version
[  +13 ms] Android Debug Bridge version 1.0.41
           Version 30.0.5-6877874
           Installed as C:\Users\Sean\AppData\Local\Android\Sdk\platform-tools\adb.exe
[   +4 ms] executing: C:\Users\Sean\AppData\Local\Android\Sdk\platform-tools\adb.exe start-server
[  +13 ms] Building APK
[  +16 ms] Running Gradle task 'assembleDevRelease'...
[   +6 ms] Using gradle from C:\Work\...\android\gradlew.bat.
[   +7 ms] executing: C:\Program Files\Android\Android Studio\jre\bin\java -version
[  +65 ms] Exit code 0 from: C:\Program Files\Android\Android Studio\jre\bin\java -version
[        ] openjdk version "1.8.0_242-release"
           OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b01)
           OpenJDK 64-Bit Server VM (build 25.242-b01, mixed mode)
[   +1 ms] executing: [C:\Work\...\android/] C:\Work\...\android\gradlew.bat -Pverbose=true -Ptarget-platform=android-arm64 -Ptarget=C:\Work\...\lib\main.dart -Pdart-defines=RkxVVFRFUl9XRUJfQVVUT19ERVRFQ1Q9dHJ1ZQ==    
-Pdart-obfuscation=false -Ptrack-widget-creation=true -Ptree-shake-icons=false -Pfilesystem-scheme=org-dartlang-root assembleDevRelease
[+3630 ms] > Task :app:compileFlutterBuildDevRelease
[        ] [  +57 ms] executing: [C:\Work\flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%%H
[        ] [  +45 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%%H
[        ] [        ] 354bd53f62ed6dd31c9addc4cce521f412c6b1aa
[  +10 ms] [        ] executing: [C:\Work\flutter/] git tag --points-at 354bd53f62ed6dd31c9addc4cce521f412c6b1aa
[        ] [  +29 ms] Exit code 0 from: git tag --points-at 354bd53f62ed6dd31c9addc4cce521f412c6b1aa
[        ] [   +1 ms] executing: [C:\Work\flutter/] git describe --match *.*.* --long --tags 354bd53f62ed6dd31c9addc4cce521f412c6b1aa
[  +11 ms] [  +44 ms] Exit code 0 from: git describe --match *.*.* --long --tags 354bd53f62ed6dd31c9addc4cce521f412c6b1aa
[        ] [        ] 1.27.0-4.0.pre-134-g354bd53f62
[        ] [  +41 ms] executing: [C:\Work\flutter/] git rev-parse --abbrev-ref HEAD
[   +1 ms] [  +20 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[   +7 ms] [        ] master
[   +7 ms] [  +37 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[   +2 ms] [        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[        ] [   +1 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[   +9 ms] [        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[   +2 ms] [        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[   +2 ms] [        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[   +7 ms] [  +38 ms] Artifact Instance of 'MaterialFonts' is not required, skipping update.
[   +8 ms] [        ] Artifact Instance of 'GradleWrapper' is not required, skipping update.
[        ] [        ] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FlutterSdk' is not required, skipping update.
[        ] [        ] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[   +3 ms] [        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[  +14 ms] [        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[   +7 ms] [        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[   +7 ms] [        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[  +11 ms] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] [        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[   +6 ms] [  +62 ms] Initializing file store
[  +25 ms] [  +17 ms] Skipping target: gen_localizations
[   +9 ms] [   +5 ms] kernel_snapshot: Starting due to {}
[   +5 ms] [  +34 ms] Found plugin keychain at C:\Work\flutter\.pub-cache\git\flutter-plugins-9c77e6954c5c4eb6d5ab2ca7825b319f96437098\keychain\keychain\
[  +13 ms] [   +3 ms] Found plugin keychain_linux at C:\Work\flutter\.pub-cache\git\flutter-plugins-9c77e6954c5c4eb6d5ab2ca7825b319f96437098\keychain\keychain_linux\
[   +3 ms] [   +1 ms] Found plugin keychain_macos at C:\Work\flutter\.pub-cache\git\flutter-plugins-9c77e6954c5c4eb6d5ab2ca7825b319f96437098\keychain\keychain_macos\
[   +8 ms] [   +1 ms] Found plugin keychain_windows at C:\Work\flutter\.pub-cache\git\flutter-plugins-9c77e6954c5c4eb6d5ab2ca7825b319f96437098\keychain\keychain_windows\
[        ] [   +2 ms] Found plugin sqflite at C:\Work\flutter\.pub-cache\git\sqflite_sqlcipher-bb2b0a7c95e3679e323c32d54722ad3f639147d8\sqflite\
[  +19 ms] [  +18 ms] Found plugin device_info at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\device_info-0.4.2+7\
[        ] [   +4 ms] Found plugin file_picker at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\file_picker-2.1.5\
[   +1 ms] [   +1 ms] Found plugin firebase_core at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_core-0.5.3\
[        ] [   +1 ms] Found plugin firebase_core_web at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_core_web-0.2.1+1\
[        ] [        ] Found plugin firebase_crashlytics at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_crashlytics-0.2.1+1\
[        ] [   +1 ms] Found plugin firebase_messaging at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_messaging-7.0.3\
[  +11 ms] [   +3 ms] Found plugin flutter_file_dialog at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_file_dialog-1.0.0\
[        ] [        ] Found plugin flutter_plugin_android_lifecycle at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_plugin_android_lifecycle-1.0.11\
[        ] [   +1 ms] Found plugin flutter_secure_storage at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_secure_storage-3.3.3\
[   +2 ms] [   +4 ms] Found plugin image_picker at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\image_picker-0.6.7+21\
[        ] [   +9 ms] Found plugin open_file at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\open_file-3.0.1\
[        ] [   +1 ms] Found plugin package_info at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\package_info-0.4.3\
[        ] [   +2 ms] Found plugin path_provider at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider-1.6.24\
[  +21 ms] [        ] Found plugin path_provider_linux at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_linux-0.0.1+2\
[        ] [        ] Found plugin path_provider_macos at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_macos-0.0.4+8\
[        ] [   +1 ms] Found plugin path_provider_windows at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_windows-0.0.4+3\
[   +2 ms] [   +7 ms] Found plugin sensors at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\sensors-0.4.2+6\
[        ] [   +5 ms] Found plugin sqflite_sqlcipher at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\sqflite_sqlcipher-1.1.4\
[        ] [   +6 ms] Found plugin url_launcher at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\url_launcher-5.4.10\
[        ] [        ] Found plugin url_launcher_macos at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\url_launcher_macos-0.0.1+9\
[   +2 ms] [   +1 ms] Found plugin url_launcher_web at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\url_launcher_web-0.1.5+3\
[        ] [   +1 ms] Found plugin video_player at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\video_player-0.10.11+1\
[  +10 ms] [   +1 ms] Found plugin video_player_web at C:\Work\flutter\.pub-cache\hosted\pub.dartlang.org\video_player_web-0.1.4+1\
[        ] [  +10 ms] C:\Work\flutter\bin\cache\dart-sdk\bin\dart.exe --disable-dart-dev C:\Work\flutter\bin\cache\artifacts\engine\windows-x64\frontend_server.dart.snapshot --sdk-root
C:\Work\flutter\bin\cache\artifacts\engine\common\flutter_patched_sdk_product/ --target=flutter --no-print-incremental-dependencies -DFLUTTER_WEB_AUTO_DETECT=true -Ddart.vm.profile=false -Ddart.vm.product=true --aot --tfa --packages
C:\Work\...\.dart_tool\package_config.json --output-dill C:\Work\...\.dart_tool\flutter_build\6a3e205f953086658b7355bb389ac54e\app.dill --depfile
C:\Work\...\.dart_tool\flutter_build\6a3e205f953086658b7355bb389ac54e\kernel_snapshot.d package:mobile_app/main.dart
[+6321 ms] [+7597 ms] ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:1111:7: Error: Struct 'ENUMLOGFONTEX' is empty. Empty structs are undefined behavior.
[   +3 ms] [   +1 ms] class ENUMLOGFONTEX extends Struct {
[        ] [        ]       ^
[  +91 ms] [  +21 ms] ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2835:7: Error: Struct 'BLUETOOTH_PIN_INFO' is empty. Empty structs are undefined behavior.
[        ] [        ] class BLUETOOTH_PIN_INFO extends Struct {
[        ] [        ]       ^
[        ] [        ] ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2960:7: Error: Struct 'EXCEPINFO' is empty. Empty structs are undefined behavior.
[   +3 ms] [        ] class EXCEPINFO extends Struct {}
[  +21 ms] [        ]       ^
[   +8 ms] [        ] ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2966:7: Error: Struct 'PROPERTYKEY' is empty. Empty structs are undefined behavior.
[   +7 ms] [        ] class PROPERTYKEY extends Struct {}
[        ] [        ]       ^
[        ] [        ] ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2973:7: Error: Struct 'PROPVARIANT' is empty. Empty structs are undefined behavior.
[        ] [        ] class PROPVARIANT extends Struct {}
[  +11 ms] [        ]       ^
[        ] [        ] ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2978:7: Error: Struct 'SAFEARRAY' is empty. Empty structs are undefined behavior.
[        ] [        ] class SAFEARRAY extends Struct {}
[   +2 ms] [        ]       ^
[  +15 ms] [        ] ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2985:7: Error: Struct 'CLSID' is empty. Empty structs are undefined behavior.
[   +6 ms] [        ] class CLSID extends Struct {}
[   +6 ms] [        ]       ^
[        ] [        ] ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2992:7: Error: Struct 'STATSTG' is empty. Empty structs are undefined behavior.
[   +2 ms] [        ] class STATSTG extends Struct {}
[        ] [        ]       ^
[        ] [        ] ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2999:7: Error: Struct 'NLM_SIMULATED_PROFILE_INFO' is empty. Empty structs are undefined behavior.
[        ] [        ] class NLM_SIMULATED_PROFILE_INFO extends Struct {}
[   +3 ms] [        ]       ^
[  +14 ms] [        ] ../../flutter/.pub-cache/hosted/pub.dartlang.org/ffi-0.1.3/lib/src/utf8.dart:23:7: Error: Struct 'Utf8' is empty. Empty structs are undefined behavior.
[        ] [        ] class Utf8 extends Struct {
[        ] [        ]       ^
[   +2 ms] [        ] ../../flutter/.pub-cache/hosted/pub.dartlang.org/ffi-0.1.3/lib/src/utf16.dart:16:7: Error: Struct 'Utf16' is empty. Empty structs are undefined behavior.
[        ] [        ] class Utf16 extends Struct {
[        ] [        ]       ^
[  +95 ms] [ +194 ms] ../../flutter/.pub-cache/hosted/pub.dartlang.org/ffi-0.1.3/lib/src/allocation.dart:47:33: Error: Expected type 'T' to be a valid and instantiated subtype of 'NativeType'.
[        ] [        ]   final int totalSize = count * sizeOf<T>();
[        ] [        ]                                 ^
[+1890 ms] [+1904 ms] Persisting file store
[        ] [   +2 ms] Done persisting file store
[        ] [   +5 ms] Target kernel_snapshot failed: Exception
[   +7 ms]            #0      KernelSnapshot.build (package:flutter_tools/src/build_system/targets/common.dart:286:7)
[        ]            <asynchronous suspension>
[        ]            #1      _BuildInstance._invokeInternal (package:flutter_tools/src/build_system/build_system.dart:808:9)
[   +2 ms]            <asynchronous suspension>
[        ]            #2      Future.wait.<anonymous closure> (dart:async/future.dart)
[        ]            <asynchronous suspension>
[        ]            #3      _BuildInstance.invokeTarget (package:flutter_tools/src/build_system/build_system.dart:746:32)
[        ]            <asynchronous suspension>
[   +7 ms]            #4      Future.wait.<anonymous closure> (dart:async/future.dart)
[        ]            <asynchronous suspension>
[   +5 ms]            #5      _BuildInstance.invokeTarget (package:flutter_tools/src/build_system/build_system.dart:746:32)
[        ]            <asynchronous suspension>
[        ]            #6      FlutterBuildSystem.build (package:flutter_tools/src/build_system/build_system.dart:575:16)
[   +2 ms]            <asynchronous suspension>
[   +5 ms]            #7      AssembleCommand.runCommand (package:flutter_tools/src/commands/assemble.dart:231:32)
[   +6 ms]            <asynchronous suspension>
[        ]            #8      FlutterCommand.verifyThenRunCommand (package:flutter_tools/src/runner/flutter_command.dart:1186:12)
[        ]            <asynchronous suspension>
[        ]            #9      FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1037:27)
[   +2 ms]            <asynchronous suspension>
[  +10 ms]            #10     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:152:19)
[   +1 ms]            <asynchronous suspension>
[   +6 ms]            #11     AppContext.run (package:flutter_tools/src/base/context.dart:151:12)
[        ]            <asynchronous suspension>
[   +4 ms]            #12     CommandRunner.runCommand (package:args/command_runner.dart:197:13)
[        ]            <asynchronous suspension>
[        ]            #13     FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:283:9)
[   +2 ms]            <asynchronous suspension>
[   +5 ms]            #14     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:152:19)
[        ]            <asynchronous suspension>
[        ]            #15     AppContext.run (package:flutter_tools/src/base/context.dart:151:12)
[        ]            <asynchronous suspension>
[   +7 ms]            #16     FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:239:5)
[        ]            <asynchronous suspension>
[        ]            #17     run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
[   +1 ms]            <asynchronous suspension>
[        ]            #18     run.<anonymous closure> (package:flutter_tools/runner.dart:60:12)
[        ]            <asynchronous suspension>
[        ]            #19     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:152:19)
[        ]            <asynchronous suspension>
[   +2 ms]            #20     AppContext.run (package:flutter_tools/src/base/context.dart:151:12)
[        ]            <asynchronous suspension>
[  +12 ms]            #21     runInContext (package:flutter_tools/src/context_runner.dart:77:10)
[        ]            <asynchronous suspension>
[        ]            #22     main (package:flutter_tools/executable.dart:92:3)
[   +1 ms]            <asynchronous suspension>
[   +5 ms] [   +3 ms] 
[        ]            #0      throwToolExit (package:flutter_tools/src/base/common.dart:12:3)
[   +6 ms]            #1      AssembleCommand.runCommand (package:flutter_tools/src/commands/assemble.dart:248:7)
[        ]            <asynchronous suspension>
[        ]            #2      FlutterCommand.verifyThenRunCommand (package:flutter_tools/src/runner/flutter_command.dart:1186:12)
[   +6 ms]            <asynchronous suspension>
[   +5 ms]            #3      FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1037:27)
[        ]            <asynchronous suspension>
[   +2 ms]            #4      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:152:19)
[   +5 ms]            <asynchronous suspension>
[        ]            #5      AppContext.run (package:flutter_tools/src/base/context.dart:151:12)
[        ]            <asynchronous suspension>
[   +6 ms]            #6      CommandRunner.runCommand (package:args/command_runner.dart:197:13)
[   +5 ms]            <asynchronous suspension>
[        ]            #7      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:283:9)
[        ]            <asynchronous suspension>
[   +1 ms]            #8      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:152:19)
[   +5 ms]            <asynchronous suspension>
[        ]            #9      AppContext.run (package:flutter_tools/src/base/context.dart:151:12)
[        ]            <asynchronous suspension>
[   +9 ms]            #10     FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:239:5)
[        ]            <asynchronous suspension>
[        ]            #11     run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
[   +2 ms]            <asynchronous suspension>
[        ]            #12     run.<anonymous closure> (package:flutter_tools/runner.dart:60:12)
[        ]            <asynchronous suspension>
[   +2 ms]            #13     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:152:19)
[   +5 ms]            <asynchronous suspension>
[   +6 ms]            #14     AppContext.run (package:flutter_tools/src/base/context.dart:151:12)
[        ]            <asynchronous suspension>
[        ]            #15     runInContext (package:flutter_tools/src/context_runner.dart:77:10)
[   +6 ms]            <asynchronous suspension>
[   +5 ms]            #16     main (package:flutter_tools/executable.dart:92:3)
[        ]            <asynchronous suspension>
[        ] FAILURE: Build failed with an exception.
[        ] * Where:
[   +2 ms] Script 'C:\Work\flutter\packages\flutter_tools\gradle\flutter.gradle' line: 991
[   +5 ms] * What went wrong:
[   +6 ms] Execution failed for task ':app:compileFlutterBuildDevRelease'.
[        ] > Process 'command 'C:\Work\flutter\bin\flutter.bat'' finished with non-zero exit value 1
[   +6 ms] * Try:
[        ] Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
[        ] * Get more help at https://help.gradle.org
[   +6 ms] BUILD FAILED in 12s
[        ] [   +7 ms] "flutter assemble" took 10,003ms.
[        ] [  +24 ms] ensureAnalyticsSent: 23ms
[   +6 ms] [   +1 ms] Running shutdown hooks
[   +6 ms] [        ] Shutdown hooks complete
[        ] [        ] exiting with code 1
[        ] > Task :app:compileFlutterBuildDevRelease FAILED
[        ] Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
[   +1 ms] Use '--warning-mode all' to show the individual deprecation warnings.
[   +4 ms] See https://docs.gradle.org/6.0.1/userguide/command_line_interface.html#sec:command_line_warnings
[        ] 1 actionable task: 1 executed
[ +444 ms] Running Gradle task 'assembleDevRelease'... (completed in 13.2s)
[   +2 ms] Exception: Gradle task assembleDevRelease failed with exit code 1
[   +5 ms] "flutter run" took 14,377ms.
[   +5 ms] 
           #0      throwToolExit (package:flutter_tools/src/base/common.dart:12:3)
           #1      RunCommand.runCommand (package:flutter_tools/src/commands/run.dart:655:9)
           <asynchronous suspension>
           #2      FlutterCommand.verifyThenRunCommand (package:flutter_tools/src/runner/flutter_command.dart:1186:12)
           <asynchronous suspension>
           #3      FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1037:27)
           <asynchronous suspension>
           #4      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:152:19)
           <asynchronous suspension>
           #5      AppContext.run (package:flutter_tools/src/base/context.dart:151:12)
           <asynchronous suspension>
           #6      CommandRunner.runCommand (package:args/command_runner.dart:197:13)
           <asynchronous suspension>
           #7      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:283:9)
           <asynchronous suspension>
           #8      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:152:19)
           <asynchronous suspension>
           #9      AppContext.run (package:flutter_tools/src/base/context.dart:151:12)
           <asynchronous suspension>
           #10     FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:239:5)
           <asynchronous suspension>
           #11     run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
           <asynchronous suspension>
           #12     run.<anonymous closure> (package:flutter_tools/runner.dart:60:12)
           <asynchronous suspension>
           #13     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:152:19)
           <asynchronous suspension>
           #14     AppContext.run (package:flutter_tools/src/base/context.dart:151:12)
           <asynchronous suspension>
           #15     runInContext (package:flutter_tools/src/context_runner.dart:77:10)
           <asynchronous suspension>
           #16     main (package:flutter_tools/executable.dart:92:3)
           <asynchronous suspension>


[  +67 ms] ensureAnalyticsSent: 22ms
[   +1 ms] Running shutdown hooks
[        ] Shutdown hook priority 4
[   +2 ms] Shutdown hooks complete
[   +4 ms] exiting with code 1

flutter doctor -v

[√] Flutter (Channel master, 1.27.0-5.0.pre.134, on Microsoft Windows [Version 10.0.19041.804], locale en-GB)
    • Flutter version 1.27.0-5.0.pre.134 at C:\Work\flutter
    • Framework revision 354bd53f62 (7 hours ago), 2021-02-24 02:36:05 -0500
    • Engine revision 9061823775
    • Dart version 2.13.0 (build 2.13.0-68.0.dev)

[√] Android toolchain - develop for Android devices (Android SDK version 30.0.3)
    • Android SDK at C:\Users\Sean\AppData\Local\Android\Sdk
    • Platform android-30, build-tools 30.0.3
    • ANDROID_SDK_ROOT = C:\Users\Sean\AppData\Local\Android\Sdk
    • Java binary at: C:\Program Files\Android\Android Studio\jre\bin\java
    • Java version OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b01)
    • All Android licenses accepted.

[√] Chrome - develop for the web
    • Chrome at C:\Program Files (x86)\Google\Chrome\Application\chrome.exe

[√] Visual Studio - develop for Windows (Visual Studio Community 2019 16.8.5)
    • Visual Studio at C:\Program Files (x86)\Microsoft Visual Studio\2019\Community
    • Visual Studio Community 2019 version 16.8.31005.135
    • Windows 10 SDK version 10.0.18362.0

[√] Android Studio (version 4.1.0)
    • Android Studio at C:\Program Files\Android\Android Studio
    • Flutter plugin can be installed from:
       https://plugins.jetbrains.com/plugin/9212-flutter
    • Dart plugin can be installed from:
       https://plugins.jetbrains.com/plugin/6351-dart
    • Java version OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b01)

[√] VS Code (version 1.53.2)
    • VS Code at C:\Users\Sean\AppData\Local\Programs\Microsoft VS Code
    • Flutter extension version 3.19.0

[√] Connected device (4 available)
    • Redmi Note 5 (mobile) • 39b812c • android-arm64  • Android 9 (API 28)
    • Windows (desktop)     • windows • windows-x64    • Microsoft Windows [Version 10.0.19041.804]
    • Chrome (web)          • chrome  • web-javascript • Google Chrome 88.0.4324.182
    • Edge (web)            • edge    • web-javascript • Microsoft Edge 88.0.705.74

• No issues found!

1 possible answer(s) on “Android build failure on master channel

  1. @seanmc86
    Can you upgrade master to latest (1.27.0-9.0.pre.85) and try again ?

    Same error after upgrading.

    flutter upgrade

    Flutter is already up to date on channel master
    Flutter 1.27.0-9.0.pre.85 • channel master • https://github.com/flutter/flutter.git
    Framework • revision 71b2b4d6e0 (6 hours ago) • 2021-02-25 00:01:01 -0500
    Engine • revision 867e51b762
    Tools • Dart 2.13.0 (build 2.13.0-73.0.dev)
    

    flutter run –release –flavor dev

    
    Launching lib\main.dart on Redmi Note 5 in release mode...
    ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:1111:7: Error: Struct 'ENUMLOGFONTEX' is empty. Empty structs are undefined behavior.
    class ENUMLOGFONTEX extends Struct {
          ^
    ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2835:7: Error: Struct 'BLUETOOTH_PIN_INFO' is empty. Empty structs are undefined behavior.
    class BLUETOOTH_PIN_INFO extends Struct {
          ^
    ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2960:7: Error: Struct 'EXCEPINFO' is empty. Empty structs are undefined behavior.
    class EXCEPINFO extends Struct {}
          ^
    ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2966:7: Error: Struct 'PROPERTYKEY' is empty. Empty structs are undefined behavior.
    class PROPERTYKEY extends Struct {}
          ^
    ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2973:7: Error: Struct 'PROPVARIANT' is empty. Empty structs are undefined behavior.
    class PROPVARIANT extends Struct {}
          ^
    ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2978:7: Error: Struct 'SAFEARRAY' is empty. Empty structs are undefined behavior.
    class SAFEARRAY extends Struct {}
          ^
    ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2985:7: Error: Struct 'CLSID' is empty. Empty structs are undefined behavior.
    class CLSID extends Struct {}
          ^
    ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2992:7: Error: Struct 'STATSTG' is empty. Empty structs are undefined behavior.
    class STATSTG extends Struct {}
          ^
    ../../flutter/.pub-cache/hosted/pub.dartlang.org/win32-1.7.4+1/lib/src/structs.dart:2999:7: Error: Struct 'NLM_SIMULATED_PROFILE_INFO' is empty. Empty structs are undefined behavior.
    class NLM_SIMULATED_PROFILE_INFO extends Struct {}
          ^
    ../../flutter/.pub-cache/hosted/pub.dartlang.org/ffi-0.1.3/lib/src/utf8.dart:23:7: Error: Struct 'Utf8' is empty. Empty structs are undefined behavior.
    class Utf8 extends Struct {
          ^
    ../../flutter/.pub-cache/hosted/pub.dartlang.org/ffi-0.1.3/lib/src/utf16.dart:16:7: Error: Struct 'Utf16' is empty. Empty structs are undefined behavior.
    class Utf16 extends Struct {
          ^
    ../../flutter/.pub-cache/hosted/pub.dartlang.org/ffi-0.1.3/lib/src/allocation.dart:47:33: Error: Expected type 'T' to be a valid and instantiated subtype of 'NativeType'.
      final int totalSize = count * sizeOf<T>();
                                    ^
                                                                            
                                                                            
    FAILURE: Build failed with an exception.
    
    * Where:
    Script 'C:\Work\flutter\packages\flutter_tools\gradle\flutter.gradle' line: 991
    
    * What went wrong:
    Execution failed for task ':app:compileFlutterBuildDevRelease'.
    > Process 'command 'C:\Work\flutter\bin\flutter.bat'' finished with non-zero exit value 1