after upgrade of flutter to 2.03 stable

i meet this error never see before how to fix thanks

_/C:/flutter/.pub-cache/hosted/pub.dartlang.org/native_device_orientation-0.3.0/lib/native_device_orientation.dart:99:17: Error: The method
‘inheritFromWidgetOfExactType’ isn’t defined for the class ‘BuildContext’.
[ +6 ms] [ +3 ms] – ‘BuildContext’ is from ‘package:flutter/src/widgets/framework.dart’ (‘/C:/flutter/packages/flutter/lib/src/widgets/framework.dart’).
[ +7 ms] [ ] Try correcting the name to the name of an existing method, or defining a method named ‘inheritFromWidgetOfExactType’.
[ +3 ms] [ +1 ms] context.inheritFromWidgetOfExactType(InheritedNativeDeviceOrientation);
[ ] [ ] ^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Logs
(c) 2020 Microsoft Corporation. Tutti i diritti sono riservati.

C:\Users\Flavi\OneDrive\Documents\csf2021exp>flutter create bug
Creating project bug...
  bug\.gitignore (created)
  bug\.idea\libraries\Dart_SDK.xml (created)
  bug\.idea\libraries\KotlinJavaRuntime.xml (created)
  bug\.idea\modules.xml (created)
  bug\.idea\runConfigurations\main_dart.xml (created)
  bug\.idea\workspace.xml (created)
  bug\.metadata (created)
  bug\android\app\build.gradle (created)
  bug\android\app\src\main\kotlin\com\example\bug\MainActivity.kt (created)
  bug\android\build.gradle (created)
  bug\android\bug_android.iml (created)
  bug\android\.gitignore (created)
  bug\android\app\src\debug\AndroidManifest.xml (created)
  bug\android\app\src\main\AndroidManifest.xml (created)
  bug\android\app\src\main\res\drawable\launch_background.xml (created)
  bug\android\app\src\main\res\drawable-v21\launch_background.xml (created)
  bug\android\app\src\main\res\mipmap-hdpi\ic_launcher.png (created)
  bug\android\app\src\main\res\mipmap-mdpi\ic_launcher.png (created)
  bug\android\app\src\main\res\mipmap-xhdpi\ic_launcher.png (created)
  bug\android\app\src\main\res\mipmap-xxhdpi\ic_launcher.png (created)
  bug\android\app\src\main\res\mipmap-xxxhdpi\ic_launcher.png (created)
  bug\android\app\src\main\res\values\styles.xml (created)
  bug\android\app\src\main\res\values-night\styles.xml (created)
  bug\android\app\src\profile\AndroidManifest.xml (created)
  bug\android\gradle\wrapper\gradle-wrapper.properties (created)
  bug\android\gradle.properties (created)
  bug\android\settings.gradle (created)
  bug\ios\Runner\AppDelegate.swift (created)
  bug\ios\Runner\Runner-Bridging-Header.h (created)
  bug\ios\Runner.xcodeproj\project.pbxproj (created)
  bug\ios\Runner.xcodeproj\xcshareddata\xcschemes\Runner.xcscheme (created)
  bug\ios\.gitignore (created)
  bug\ios\Flutter\AppFrameworkInfo.plist (created)
  bug\ios\Flutter\Debug.xcconfig (created)
  bug\ios\Flutter\Release.xcconfig (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Contents.json (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-1024x1024@1x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-20x20@1x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-20x20@2x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-20x20@3x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-29x29@1x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-29x29@2x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-29x29@3x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-40x40@1x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-40x40@2x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-40x40@3x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-60x60@2x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-60x60@3x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-76x76@1x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-76x76@2x.png (created)
  bug\ios\Runner\Assets.xcassets\AppIcon.appiconset\Icon-App-83.5x83.5@2x.png (created)
  bug\ios\Runner\Assets.xcassets\LaunchImage.imageset\Contents.json (created)
  bug\ios\Runner\Assets.xcassets\LaunchImage.imageset\LaunchImage.png (created)
  bug\ios\Runner\Assets.xcassets\LaunchImage.imageset\LaunchImage@2x.png (created)
  bug\ios\Runner\Assets.xcassets\LaunchImage.imageset\LaunchImage@3x.png (created)
  bug\ios\Runner\Assets.xcassets\LaunchImage.imageset\README.md (created)
  bug\ios\Runner\Base.lproj\LaunchScreen.storyboard (created)
  bug\ios\Runner\Base.lproj\Main.storyboard (created)
  bug\ios\Runner\Info.plist (created)
  bug\ios\Runner.xcodeproj\project.xcworkspace\contents.xcworkspacedata (created)
  bug\ios\Runner.xcodeproj\project.xcworkspace\xcshareddata\IDEWorkspaceChecks.plist (created)
  bug\ios\Runner.xcodeproj\project.xcworkspace\xcshareddata\WorkspaceSettings.xcsettings (created)
  bug\ios\Runner.xcworkspace\contents.xcworkspacedata (created)
  bug\ios\Runner.xcworkspace\xcshareddata\IDEWorkspaceChecks.plist (created)
  bug\ios\Runner.xcworkspace\xcshareddata\WorkspaceSettings.xcsettings (created)
  bug\lib\main.dart (created)
  bug\bug.iml (created)
  bug\pubspec.yaml (created)
  bug\README.md (created)
  bug\test\widget_test.dart (created)
  bug\web\favicon.png (created)
  bug\web\icons\Icon-192.png (created)
  bug\web\icons\Icon-512.png (created)
  bug\web\index.html (created)
  bug\web\manifest.json (created)
Running "flutter pub get" in bug...                                 6,0s
Wrote 78 files.

All done!
In order to run your application, type:

  $ cd bug
  $ flutter run

To enable null safety, type:

  $ cd bug
  $ dart migrate --apply-changes

Your application code is in bug\lib\main.dart.


C:\Users\Flavi\OneDrive\Documents\csf2021exp>flutter run --verbose
[ +222 ms] executing: [C:\flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%%H
[ +675 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%%H
[   +3 ms] 4d7946a68d26794349189cf21b3f68cc6fe61dcb
[   +3 ms] executing: [C:\flutter/] git tag --points-at 4d7946a68d26794349189cf21b3f68cc6fe61dcb
[ +365 ms] Exit code 0 from: git tag --points-at 4d7946a68d26794349189cf21b3f68cc6fe61dcb
[   +1 ms] 2.0.3
[ +108 ms] executing: [C:\flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[ +315 ms] Exit code 0 from: git rev-parse --abbrev-ref --symbolic @{u}
[   +1 ms] origin/stable
[   +1 ms] executing: [C:\flutter/] git ls-remote --get-url origin
[ +318 ms] Exit code 0 from: git ls-remote --get-url origin
[   +1 ms] https://github.com/flutter/flutter.git
[ +396 ms] executing: [C:\flutter/] git rev-parse --abbrev-ref HEAD
[ +317 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[   +2 ms] stable
[ +175 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[  +10 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[ +170 ms] executing: C:\Users\Flavi\AppData\Local\Android\sdk\platform-tools\adb.exe devices -l
[ +117 ms] List of devices attached
                    emulator-5554          device product:sdk_gphone_x86_arm model:sdk_gphone_x86_arm device:generic_x86_arm transport_id:1
[  +17 ms] C:\Users\Flavi\AppData\Local\Android\sdk\platform-tools\adb.exe -s emulator-5554 shell getprop
[ +145 ms] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[  +10 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[   +2 ms] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[ +257 ms] Skipping pub get: version match.
[  +62 ms] Found plugin camera at C:\flutter\.pub-cache\hosted\pub.dartlang.org\camera-0.5.8+17\
[  +35 ms] Found plugin cloud_firestore at C:\flutter\.pub-cache\hosted\pub.dartlang.org\cloud_firestore-0.13.7\
[  +14 ms] Found plugin cloud_firestore_web at C:\flutter\.pub-cache\hosted\pub.dartlang.org\cloud_firestore_web-0.1.1+2\
[  +32 ms] Found plugin firebase_admob at C:\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_admob-0.9.3+4\
[   +8 ms] Found plugin firebase_auth at C:\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_auth-0.16.1\
[  +11 ms] Found plugin firebase_auth_web at C:\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_auth_web-0.1.3+1\
[   +7 ms] Found plugin firebase_core at C:\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_core-0.4.5\
[  +11 ms] Found plugin firebase_core_web at C:\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_core_web-0.1.1+2\
[   +9 ms] Found plugin firebase_storage at C:\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_storage-3.1.6\
[   +6 ms] Found plugin flutter_native_image at C:\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_native_image-0.0.5+3\
[   +8 ms] Found plugin flutter_plugin_android_lifecycle at C:\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_plugin_android_lifecycle-1.0.11\
[  +10 ms] Found plugin geolocator at C:\flutter\.pub-cache\hosted\pub.dartlang.org\geolocator-5.3.2+2\
[   +9 ms] Found plugin google_api_availability at C:\flutter\.pub-cache\hosted\pub.dartlang.org\google_api_availability-2.0.4\
[   +6 ms] Found plugin google_maps_flutter at C:\flutter\.pub-cache\hosted\pub.dartlang.org\google_maps_flutter-0.5.33\
[  +11 ms] Found plugin google_sign_in at C:\flutter\.pub-cache\hosted\pub.dartlang.org\google_sign_in-4.5.9\
[  +10 ms] Found plugin google_sign_in_web at C:\flutter\.pub-cache\hosted\pub.dartlang.org\google_sign_in_web-0.9.2\
[  +13 ms] Found plugin image_picker at C:\flutter\.pub-cache\hosted\pub.dartlang.org\image_picker-0.6.7+4\
[  +14 ms] Found plugin location_permissions at C:\flutter\.pub-cache\hosted\pub.dartlang.org\location_permissions-3.0.0+1\
[  +10 ms] Found plugin native_device_orientation at C:\flutter\.pub-cache\hosted\pub.dartlang.org\native_device_orientation-0.3.0\
[   +7 ms] Found plugin path_provider at C:\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider-1.6.28\
[   +5 ms] Found plugin path_provider_linux at C:\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_linux-0.0.1+2\
[   +6 ms] Found plugin path_provider_macos at C:\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_macos-0.0.4+8\
[   +9 ms] Found plugin path_provider_windows at C:\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_windows-0.0.5\
[  +64 ms] Found plugin video_player at C:\flutter\.pub-cache\hosted\pub.dartlang.org\video_player-1.0.1\
[   +8 ms] Found plugin video_player_web at C:\flutter\.pub-cache\hosted\pub.dartlang.org\video_player_web-0.1.4+1\
[   +5 ms] Found plugin wakelock at C:\flutter\.pub-cache\hosted\pub.dartlang.org\wakelock-0.1.4+2\
[ +228 ms] Found plugin camera at C:\flutter\.pub-cache\hosted\pub.dartlang.org\camera-0.5.8+17\
[  +18 ms] Found plugin cloud_firestore at C:\flutter\.pub-cache\hosted\pub.dartlang.org\cloud_firestore-0.13.7\
[   +8 ms] Found plugin cloud_firestore_web at C:\flutter\.pub-cache\hosted\pub.dartlang.org\cloud_firestore_web-0.1.1+2\
[  +23 ms] Found plugin firebase_admob at C:\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_admob-0.9.3+4\
[   +9 ms] Found plugin firebase_auth at C:\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_auth-0.16.1\
[   +7 ms] Found plugin firebase_auth_web at C:\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_auth_web-0.1.3+1\
[   +4 ms] Found plugin firebase_core at C:\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_core-0.4.5\
[   +8 ms] Found plugin firebase_core_web at C:\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_core_web-0.1.1+2\
[   +4 ms] Found plugin firebase_storage at C:\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_storage-3.1.6\
[   +5 ms] Found plugin flutter_native_image at C:\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_native_image-0.0.5+3\
[   +5 ms] Found plugin flutter_plugin_android_lifecycle at C:\flutter\.pub-cache\hosted\pub.dartlang.org\flutter_plugin_android_lifecycle-1.0.11\
[   +6 ms] Found plugin geolocator at C:\flutter\.pub-cache\hosted\pub.dartlang.org\geolocator-5.3.2+2\
[   +6 ms] Found plugin google_api_availability at C:\flutter\.pub-cache\hosted\pub.dartlang.org\google_api_availability-2.0.4\
[  +17 ms] Found plugin google_maps_flutter at C:\flutter\.pub-cache\hosted\pub.dartlang.org\google_maps_flutter-0.5.33\
[   +8 ms] Found plugin google_sign_in at C:\flutter\.pub-cache\hosted\pub.dartlang.org\google_sign_in-4.5.9\
[   +9 ms] Found plugin google_sign_in_web at C:\flutter\.pub-cache\hosted\pub.dartlang.org\google_sign_in_web-0.9.2\
[  +13 ms] Found plugin image_picker at C:\flutter\.pub-cache\hosted\pub.dartlang.org\image_picker-0.6.7+4\
[   +9 ms] Found plugin location_permissions at C:\flutter\.pub-cache\hosted\pub.dartlang.org\location_permissions-3.0.0+1\
[   +9 ms] Found plugin native_device_orientation at C:\flutter\.pub-cache\hosted\pub.dartlang.org\native_device_orientation-0.3.0\
[   +7 ms] Found plugin path_provider at C:\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider-1.6.28\
[   +4 ms] Found plugin path_provider_linux at C:\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_linux-0.0.1+2\
[   +3 ms] Found plugin path_provider_macos at C:\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_macos-0.0.4+8\
[   +5 ms] Found plugin path_provider_windows at C:\flutter\.pub-cache\hosted\pub.dartlang.org\path_provider_windows-0.0.5\
[  +48 ms] Found plugin video_player at C:\flutter\.pub-cache\hosted\pub.dartlang.org\video_player-1.0.1\
[  +11 ms] Found plugin video_player_web at C:\flutter\.pub-cache\hosted\pub.dartlang.org\video_player_web-0.1.4+1\
[   +5 ms] Found plugin wakelock at C:\flutter\.pub-cache\hosted\pub.dartlang.org\wakelock-0.1.4+2\
[  +56 ms] Generating C:\Users\Flavi\OneDrive\Documents\csf2021exp\android\app\src\main\java\io\flutter\plugins\GeneratedPluginRegistrant.java
[ +157 ms] ro.hardware = ranchu
[  +62 ms] Using hardware rendering with device sdk gphone x86 arm. If you notice graphics artifacts, consider enabling software rendering with "--enable-software-rendering".
[  +90 ms] Initializing file store
[  +29 ms] Skipping target: gen_localizations
[  +12 ms] complete
[  +12 ms] Launching lib\main.dart on sdk gphone x86 arm in debug mode...
[  +17 ms] C:\flutter\bin\cache\dart-sdk\bin\dart.exe --disable-dart-dev C:\flutter\bin\cache\artifacts\engine\windows-x64\frontend_server.dart.snapshot --sdk-root
C:\flutter\bin\cache\artifacts\engine\common\flutter_patched_sdk/ --incremental --target=flutter --debugger-module-names --experimental-emit-debug-metadata --output-dill
C:\Users\Flavi\AppData\Local\Temp\flutter_tools.3eb19c6\flutter_tool.c3da6aa1\app.dill --packages C:\Users\Flavi\OneDrive\Documents\csf2021exp\.dart_tool\package_config.json
-Ddart.vm.profile=false -Ddart.vm.product=false --enable-asserts --track-widget-creation --filesystem-scheme org-dartlang-root --initialize-from-dill
build\cache.dill.track.dill
[  +50 ms] executing: C:\Users\Flavi\AppData\Local\Android\sdk\platform-tools\adb.exe -s emulator-5554 shell -x logcat -v time -t 1
[  +49 ms] <- compile package:csf.map.v1/main.dart
[ +151 ms] --------- beginning of kernel
                    03-24 05:24:16.785 D/logd    (    0): logdr: UID=2000 GID=2000 PID=9488 n tail=1 logMask=99 pid=0 start=0ns timeout=0ns
[  +41 ms] executing: C:\Users\Flavi\AppData\Local\Android\sdk\platform-tools\adb.exe version
[ +155 ms] Android Debug Bridge version 1.0.41
                    Version 31.0.1-7187441
                    Installed as C:\Users\Flavi\AppData\Local\Android\sdk\platform-tools\adb.exe
[   +8 ms] executing: C:\Users\Flavi\AppData\Local\Android\sdk\platform-tools\adb.exe start-server
[  +80 ms] Building APK
[  +52 ms] Running Gradle task 'assembleDebug'...
[  +14 ms] Using gradle from C:\Users\Flavi\OneDrive\Documents\csf2021exp\android\gradlew.bat.
[   +3 ms] C:\Users\Flavi\OneDrive\Documents\csf2021exp\android\gradlew.bat mode: 33279 rwxrwxrwx.
[  +28 ms] executing: C:\Program Files\Android\Android Studio\jre\bin\java -version
[ +215 ms] Exit code 0 from: C:\Program Files\Android\Android Studio\jre\bin\java -version
[   +1 ms] openjdk version "1.8.0_242-release"
           OpenJDK Runtime Environment (build 1.8.0_242-release-1644-b01)
           OpenJDK 64-Bit Server VM (build 25.242-b01, mixed mode)
[   +6 ms] executing: [C:\Users\Flavi\OneDrive\Documents\csf2021exp\android/] C:\Users\Flavi\OneDrive\Documents\csf2021exp\android\gradlew.bat -Pverbose=true
-Ptarget-platform=android-x86 -Ptarget=C:\Users\Flavi\OneDrive\Documents\csf2021exp\lib\main.dart -Ptrack-widget-creation=true -Pfilesystem-scheme=org-dartlang-root
assembleDebug
[+2108 ms] Welcome to Gradle 6.7!
[   +3 ms] Here are the highlights of this release:
[   +1 ms]  - File system watching is ready for production use
[   +1 ms]  - Declare the version of Java your build requires
[   +1 ms]  - Java 15 support
[   +1 ms] For more details see https://docs.gradle.org/6.7/release-notes.html
[+3372 ms] > Configure project :app
[ +446 ms] Plugin project :firebase_core_web not found. Please update settings.gradle.
[   +9 ms] Plugin project :cloud_firestore_web not found. Please update settings.gradle.
[   +1 ms] Plugin project :firebase_auth_web not found. Please update settings.gradle.
[+1424 ms] > Configure project :flutter_plugin_android_lifecycle
[ +220 ms] WARNING: The option setting 'android.enableR8=true' is deprecated.
[   +3 ms] It will be removed in version 5.0 of the Android Gradle plugin.
[   +1 ms] You will no longer be able to disable R8
[+7760 ms] > Task :app:compileFlutterBuildDebug
[   +3 ms] [ +241 ms] executing: [C:\flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%%H
[ +611 ms] [ +657 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%%H
[  +97 ms] [        ] 4d7946a68d26794349189cf21b3f68cc6fe61dcb
[   +2 ms] [   +1 ms] executing: [C:\flutter/] git tag --points-at 4d7946a68d26794349189cf21b3f68cc6fe61dcb
[ +296 ms] [ +356 ms] Exit code 0 from: git tag --points-at 4d7946a68d26794349189cf21b3f68cc6fe61dcb
[   +2 ms] [        ] 2.0.3
[  +91 ms] [  +98 ms] executing: [C:\flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[ +299 ms] [ +341 ms] Exit code 0 from: git rev-parse --abbrev-ref --symbolic @{u}
[   +2 ms] [        ] origin/stable
[   +1 ms] [        ] executing: [C:\flutter/] git ls-remote --get-url origin
[ +389 ms] [ +320 ms] Exit code 0 from: git ls-remote --get-url origin
[   +2 ms] [        ] https://github.com/flutter/flutter.git
[ +410 ms] [ +426 ms] executing: [C:\flutter/] git rev-parse --abbrev-ref HEAD
[ +396 ms] [ +354 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[   +2 ms] [        ] stable
[  +90 ms] [ +134 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[   +2 ms] [        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[   +2 ms] [        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[   +1 ms] [   +9 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[   +2 ms] [        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[   +2 ms] [        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[ +187 ms] [ +179 ms] Artifact Instance of 'MaterialFonts' is not required, skipping update.
[   +3 ms] [        ] Artifact Instance of 'GradleWrapper' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'FlutterSdk' is not required, skipping update.
[   +2 ms] [        ] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[   +2 ms] [        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[   +2 ms] [        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[   +3 ms] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[   +1 ms] [        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[   +2 ms] [        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[   +2 ms] [        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[ +163 ms] [ +217 ms] Initializing file store
[ +104 ms] [  +48 ms] Skipping target: gen_localizations
[   +2 ms] [  +19 ms] kernel_snapshot: Starting due to {}
[   +1 ms] [  +52 ms] C:\flutter\bin\cache\dart-sdk\bin\dart.exe --disable-dart-dev C:\flutter\bin\cache\artifacts\engine\windows-x64\frontend_server.dart.snapshot --sdk-root
C:\flutter\bin\cache\artifacts\engine\common\flutter_patched_sdk/ --target=flutter --no-print-incremental-dependencies -Ddart.vm.profile=false -Ddart.vm.product=false
--enable-asserts --track-widget-creation --no-link-platform --packages C:\Users\Flavi\OneDrive\Documents\csf2021exp\.dart_tool\package_config.json --output-dill
C:\Users\Flavi\OneDrive\Documents\csf2021exp\.dart_tool\flutter_build\88401ee4ff68cdc7fb86388b61b569bc\app.dill --depfile
C:\Users\Flavi\OneDrive\Documents\csf2021exp\.dart_tool\flutter_build\88401ee4ff68cdc7fb86388b61b569bc\kernel_snapshot.d package:csf.map.v1/main.dart
[+3609 ms] /C:/flutter/.pub-cache/hosted/pub.dartlang.org/native_device_orientation-0.3.0/lib/native_device_orientation.dart:99:17: Error: The method
'inheritFromWidgetOfExactType' isn't defined for the class 'BuildContext'.
[   +3 ms]  - 'BuildContext' is from 'package:flutter/src/widgets/framework.dart' ('/C:/flutter/packages/flutter/lib/src/widgets/framework.dart').
[   +1 ms] Try correcting the name to the name of an existing method, or defining a method named 'inheritFromWidgetOfExactType'.
[   +1 ms]         context.inheritFromWidgetOfExactType(_InheritedNativeDeviceOrientation);
[   +1 ms]                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
[+19862 ms] [+23453 ms] /C:/flutter/.pub-cache/hosted/pub.dartlang.org/native_device_orientation-0.3.0/lib/native_device_orientation.dart:99:17: Error: The method
'inheritFromWidgetOfExactType' isn't defined for the class 'BuildContext'.
[   +6 ms] [   +3 ms]  - 'BuildContext' is from 'package:flutter/src/widgets/framework.dart' ('/C:/flutter/packages/flutter/lib/src/widgets/framework.dart').
[   +7 ms] [        ] Try correcting the name to the name of an existing method, or defining a method named 'inheritFromWidgetOfExactType'.
[   +3 ms] [   +1 ms]         context.inheritFromWidgetOfExactType(_InheritedNativeDeviceOrientation);
[        ] [        ]                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
[+17300 ms] [+17339 ms] Persisting file store
[   +2 ms] [   +8 ms] Done persisting file store
[  +99 ms] [  +14 ms] Target kernel_snapshot failed: Exception
[   +2 ms]            #0      KernelSnapshot.build (package:flutter_tools/src/build_system/targets/common.dart:278:7)
[  +46 ms]            <asynchronous suspension>
[  +23 ms]            #1      _BuildInstance._invokeInternal (package:flutter_tools/src/build_system/build_system.dart:796:9)
[  +37 ms]            <asynchronous suspension>
[   +2 ms]            #2      Future.wait.<anonymous closure> (dart:async/future.dart)
[   +5 ms]            <asynchronous suspension>
[  +99 ms]            #3      _BuildInstance.invokeTarget (package:flutter_tools/src/build_system/build_system.dart:734:32)
[ +187 ms]            <asynchronous suspension>
[  +14 ms]            #4      FlutterBuildSystem.build (package:flutter_tools/src/build_system/build_system.dart:563:16)
[  +21 ms]            <asynchronous suspension>
[   +1 ms]            #5      AssembleCommand.runCommand (package:flutter_tools/src/commands/assemble.dart:220:32)
[   +1 ms]            <asynchronous suspension>
[  +22 ms]            #6      FlutterCommand.verifyThenRunCommand (package:flutter_tools/src/runner/flutter_command.dart:1157:12)
[   +4 ms]            <asynchronous suspension>
[   +5 ms]            #7      FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1009:27)
[  +32 ms]            <asynchronous suspension>
[  +60 ms]            #8      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[   +2 ms]            <asynchronous suspension>
[  +20 ms]            #9      AppContext.run (package:flutter_tools/src/base/context.dart:149:12)
[  +68 ms]            <asynchronous suspension>
[   +5 ms]            #10     CommandRunner.runCommand (package:args/command_runner.dart:197:13)
[   +2 ms]            <asynchronous suspension>
[   +6 ms]            #11     FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:278:9)
[   +1 ms]            <asynchronous suspension>
[   +2 ms]            #12     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[   +3 ms]            <asynchronous suspension>
[   +1 ms]            #13     AppContext.run (package:flutter_tools/src/base/context.dart:149:12)
[   +1 ms]            <asynchronous suspension>
[   +3 ms]            #14     FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:234:5)
[   +1 ms]            <asynchronous suspension>
[   +1 ms]            #15     run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:64:9)
[   +1 ms]            <asynchronous suspension>
[   +1 ms]            #16     run.<anonymous closure> (package:flutter_tools/runner.dart:62:12)
[   +4 ms]            <asynchronous suspension>
[   +3 ms]            #17     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[   +3 ms]            <asynchronous suspension>
[   +1 ms]            #18     AppContext.run (package:flutter_tools/src/base/context.dart:149:12)
[   +1 ms]            <asynchronous suspension>
[   +1 ms]            #19     runInContext (package:flutter_tools/src/context_runner.dart:73:10)
[   +7 ms]            <asynchronous suspension>
[   +1 ms]            #20     main (package:flutter_tools/executable.dart:90:3)
[   +1 ms]            <asynchronous suspension>
[   +4 ms] [  +10 ms] 
[   +2 ms]            #0      throwToolExit (package:flutter_tools/src/base/common.dart:10:3)
[  +10 ms]            #1      AssembleCommand.runCommand (package:flutter_tools/src/commands/assemble.dart:237:7)
[  +14 ms]            <asynchronous suspension>
[   +2 ms]            #2      FlutterCommand.verifyThenRunCommand (package:flutter_tools/src/runner/flutter_command.dart:1157:12)
[   +3 ms]            <asynchronous suspension>
[   +1 ms]            #3      FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1009:27)
[   +1 ms]            <asynchronous suspension>
[   +1 ms]            #4      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[   +6 ms]            <asynchronous suspension>
[   +1 ms]            #5      AppContext.run (package:flutter_tools/src/base/context.dart:149:12)
[   +1 ms]            <asynchronous suspension>
[   +2 ms]            #6      CommandRunner.runCommand (package:args/command_runner.dart:197:13)
[   +1 ms]            <asynchronous suspension>
[   +1 ms]            #7      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:278:9)
[   +6 ms]            <asynchronous suspension>
[   +2 ms]            #8      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[   +1 ms]            <asynchronous suspension>
[   +1 ms]            #9      AppContext.run (package:flutter_tools/src/base/context.dart:149:12)
[   +2 ms]            <asynchronous suspension>
[   +1 ms]            #10     FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:234:5)
[   +6 ms]            <asynchronous suspension>
[   +1 ms]            #11     run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:64:9)
[   +1 ms]            <asynchronous suspension>
[   +1 ms]            #12     run.<anonymous closure> (package:flutter_tools/runner.dart:62:12)
[   +3 ms]            <asynchronous suspension>
[   +8 ms]            #13     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
[   +2 ms]            <asynchronous suspension>
[   +1 ms]            #14     AppContext.run (package:flutter_tools/src/base/context.dart:149:12)
[   +1 ms]            <asynchronous suspension>
[   +2 ms]            #15     runInContext (package:flutter_tools/src/context_runner.dart:73:10)
[   +3 ms]            <asynchronous suspension>
[   +2 ms]            #16     main (package:flutter_tools/executable.dart:90:3)
[   +1 ms]            <asynchronous suspension>
[   +7 ms] FAILURE: Build failed with an exception.
[   +1 ms] * Where:
[   +3 ms] Script 'C:\flutter\packages\flutter_tools\gradle\flutter.gradle' line: 991
[   +3 ms] * What went wrong:
[   +2 ms] Execution failed for task ':app:compileFlutterBuildDebug'.
[   +2 ms] > Process 'command 'C:\flutter\bin\flutter.bat'' finished with non-zero exit value 1
[   +2 ms] * Try:
[   +3 ms] Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
[   +1 ms] * Get more help at https://help.gradle.org
[   +3 ms] BUILD FAILED in 59s
[   +3 ms] [  +33 ms] "flutter assemble" took 41.434ms.
[   +1 ms] [   +7 ms] ensureAnalyticsSent: 1ms
[   +6 ms] [   +3 ms] Running shutdown hooks
[   +1 ms] [        ] Shutdown hooks complete
[   +2 ms] [   +1 ms] exiting with code 1
[   +1 ms] > Task :app:compileFlutterBuildDebug FAILED
[   +1 ms] Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
[   +2 ms] Use '--warning-mode all' to show the individual deprecation warnings.
[   +1 ms] See https://docs.gradle.org/6.7/userguide/command_line_interface.html#sec:command_line_warnings
[   +3 ms] 1 actionable task: 1 executed
[ +354 ms] Running Gradle task 'assembleDebug'... (completed in 61,0s)
[  +10 ms] Exception: Gradle task assembleDebug failed with exit code 1
[   +4 ms] "flutter run" took 63.749ms.
[  +13 ms] 
           #0      throwToolExit (package:flutter_tools/src/base/common.dart:10:3)
           #1      RunCommand.runCommand (package:flutter_tools/src/commands/run.dart:644:9)
           <asynchronous suspension>
           #2      FlutterCommand.verifyThenRunCommand (package:flutter_tools/src/runner/flutter_command.dart:1157:12)
           <asynchronous suspension>
           #3      FlutterCommand.run.<anonymous closure> (package:flutter_tools/src/runner/flutter_command.dart:1009:27)
           <asynchronous suspension>
           #4      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #5      AppContext.run (package:flutter_tools/src/base/context.dart:149:12)
           <asynchronous suspension>
           #6      CommandRunner.runCommand (package:args/command_runner.dart:197:13)
           <asynchronous suspension>
           #7      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:278:9)
           <asynchronous suspension>
           #8      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #9      AppContext.run (package:flutter_tools/src/base/context.dart:149:12)
           <asynchronous suspension>
           #10     FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:234:5)
           <asynchronous suspension>
           #11     run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:64:9)
           <asynchronous suspension>
           #12     run.<anonymous closure> (package:flutter_tools/runner.dart:62:12)
           <asynchronous suspension>
           #13     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #14     AppContext.run (package:flutter_tools/src/base/context.dart:149:12)
           <asynchronous suspension>
           #15     runInContext (package:flutter_tools/src/context_runner.dart:73:10)
           <asynchronous suspension>
           #16     main (package:flutter_tools/executable.dart:90:3)
           <asynchronous suspension>
           
           
[ +195 ms] ensureAnalyticsSent: 187ms
[   +6 ms] Running shutdown hooks
[   +2 ms] Shutdown hook priority 4
[  +16 ms] Shutdown hooks complete
[   +9 ms] exiting with code 1

1 possible answer(s) on “after upgrade of flutter to 2.03 stable