5.2.4 symfony/phpunit-bridge changed some direct-dependency deprecation to self one.

Symfony version(s) affected: 5.2.4

Description

How to reproduce
With 5.2.3 version, Sonata build were green: https://github.com/sonata-project/SonataPageBundle/runs/1952183310
With 5.2.4 version, it doesn’t: https://github.com/sonata-project/SonataPageBundle/pull/1284/checks?check_run_id=2048123569

For instance:

1x: The "Sonata\PageBundle\Command\BaseCommand" class extends "Symfony\Bundle\FrameworkBundle\Command\ContainerAwareCommand" that is deprecated since Symfony 4.2, use {@see Command} instead.
    1x in BaseCommandTest::setUp from Sonata\PageBundle\Tests\Command

Moved from Remaining direct deprecation notices to Remaining self deprecation notices.

I think it’s a bug:

  • If I introduce a deprecation in the Sonata code, I expect this to be reported as a self deprecation. And I expect to update all the code/tests. Since I introduce the deprecation, I can provide a BC way to update the code.
  • If someone introduce a deprecation in a vendor, this should be a direct-dependency deprecation, this should not be reported as a self one because I extends this final/deprecated class. Because build shouldn’t start failing for a version bump, and because public library are not always able to fix the deprecation in a BC way.

Is it related to #40067 @nicolas-grekas ?

1 possible answer(s) on “5.2.4 symfony/phpunit-bridge changed some direct-dependency deprecation to self one.