[1.3] Can’t run apps on Windows

_10 Upvotes_ Hello I’m getting this error trying to run meteor on Windows 10 64 bits

Errors prevented startup:

While loading plugin `compileTemplatesBatch` from package `templating`:
module.js:338:15: Cannot find module '../modules/es6.object.get-own-property-descriptor'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous>
(C:\Users\juanj\AppData\Local\.meteor\packages\templating\1.1.7\plugin.compileTemplatesBatch.os\npm\node_modules\mete
ecmascript-runtime\node_modules\meteor\ecmascript-runtime\node_modules\meteor-ecmascript-runtime\node_modules\core-js
6\object.js:12:1)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous>
(C:\Users\juanj\AppData\Local\.meteor\packages\templating\1.1.7\plugin.compileTemplatesBatch.os\npm\node_modules\mete
ecmascript-runtime\node_modules\meteor\ecmascript-runtime\node_modules\meteor-ecmascript-runtime\server.js:1:1)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at npmRequire (C:\tools\isobuild\bundler.js:1665:14)
at Module.useNode (packages/modules-runtime.js:453:20)
at fileEvaluate (packages/modules-runtime.js:157:20)
at require (packages/modules-runtime.js:92:16)
at meteorInstall.node_modules.meteor.ecmascript-runtime.runtime.js (packages/ecmascript-runtime.js:24:18)
at fileEvaluate (packages/modules-runtime.js:158:9)
at require (packages/modules-runtime.js:92:16)
at packages/ecmascript-runtime.js:2832:15
at packages/ecmascript-runtime.js:2845:3


Your application has errors. Waiting for file change.

Steps to reproduce:

meteor create test-app
cd test-app
meteor 

5 thoughts on “[1.3] Can’t run apps on Windows

  1. I’m using the previous version 1.2.1 to avoid temporally this issue

    meteor create --release 1.2.1 test-app
    cd test-app
    meteor
    
  2. I deleted the templating, ecmascript, and standard-minifier-css packages, which were redownloaded and now I am able to build successfully.

  3. @ras1 That worked perfectly to resolve running the ‘Simple-todos’ sample App. I’m on Windows 10 x64 and these are the steps I took to resolve as you mentioned.

    1. Navigate to “C:\Users\alozano\AppData\Local.meteor\packages”
    2. Delete the issue package folders entirely (templating, ecmascript, standard-minifier-css)
    3. Run your terminal window, I used PowerShell and ran as Administrator to ensure no issues.
    4. Make sure your terminal is in the correct directory where your App is located.
    5. Run “meteor” and wait patiently as it attempts to download the missing packages, this might take a while.
  4. Please support to resolve this issue.
    Now I can not run any existing projects, even when I create a new one.
    Cant do anything with this issue.
    I tried to uninstall meteor and delelted all files in User\local… but it doesnt work.
    `Errors prevented startup:

    While processing files with ecmascript (for target web.browser):
    module.js:338:15: Cannot find module ‘babel-plugin-transform-runtime’
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.
    (C:\Users\Anh\AppData\Local.meteor\packages\ecmascript\0.4.1\plugin.compile-ecmascript.os\npm\node_modules\meteor\babel-compiler\node_modules\meteor\babel-compiler\node_modules\meteor-babel\node_modules\babel-preset-meteor\index.js:4:6)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.getDefaults
    (C:\Users\Anh\AppData\Local.meteor\packages\ecmascript\0.4.1\plugin.compile-ecmascript.os\npm\node_modules\meteor\babel-compiler\node_modules\meteor\babel-compiler\node_modules\meteor-babel\options.js:11:15)
    at Object.getDefaultOptions (packages/babel-compiler.js:42:29)
    at packages/babel-compiler.js:133:32
    at Array.forEach (native)
    at BabelCompiler.BCp.processFilesForTarget
    (packages/babel-compiler.js:99:14)

    While processing files with ecmascript (for target os.windows.x86_32):
    module.js:338:15: Cannot find module ‘babel-plugin-transform-runtime’
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.
    (C:\Users\Anh\AppData\Local.meteor\packages\ecmascript\0.4.1\plugin.compile-ecmascript.os\npm\node_modules\meteor\babel-compiler\node_modules\meteor\babel-compiler\node_modules\meteor-babel\node_modules\babel-preset-meteor\index.js:4:6)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.getDefaults
    (C:\Users\Anh\AppData\Local.meteor\packages\ecmascript\0.4.1\plugin.compile-ecmascript.os\npm\node_modules\meteor\babel-compiler\node_modules\meteor\babel-compiler\node_modules\meteor-babel\options.js:11:15)
    at Object.getDefaultOptions (packages/babel-compiler.js:42:29)
    at packages/babel-compiler.js:133:32
    at Array.forEach (native)
    at BabelCompiler.BCp.processFilesForTarget
    (packages/babel-compiler.js:99:14)

    => Your application has errors. Waiting for file change.`

    It stucks and consume time!!!

Comments are closed.